现在的位置: 首页 > 综合 > 正文

hdu 1058 经典DP,不过优先队列也不错,输出格式注意

2018年04月26日 ⁄ 综合 ⁄ 共 2897字 ⁄ 字号 评论关闭

优先队列注意map的使用

DP重在思想,result记录最小的值,而用四个类似指针作用的变量,a,b,c,d.每次我们比较 result[i2] * 2, result[i3] * 3, result[i5] * 5, result[i7] * 7这四个元素的大小,
把最小的放到序列中, 并把对应的指针+1,直到生成需要的个数.

输出格式:
数字后面加 th,读音和原来的序数词是一样的,如:365th,就读作:three hundred and fifty-sixth , 12th 读 twelfth
不知道你的其它数字后面加的字母是什么意思,如果是序数词,那后面的字母是不能乱加的,只有第一、第二十一、第三十一、第四十一....... 等后面可以加 -st(如:1st,21st,31st,41st......) ;第二、第二十二、第三十二、第四十二....... 等的后面可以加 -nd (如:2nd, 22nd, 32nd, 42nd......); 第三、第二十三、第三十三、第四十三....等后面可以加 -rd (如:3rd, 23rd, 33rd,43rd.....);其它的情况一律加 th(如:4th,
26th, 37th, 108th ........)

 

Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Write a program to find and print the nth element in this sequence

 

 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

 

Sample Input
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

 

Sample Output
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
 

优先队列代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<map>
#include<queue>
#include<string>
#include<algorithm>
using namespace std;
map<long long ,bool>mark;
priority_queue<long long ,vector<long long>, greater<long long> >q;
long long result[5844];
int fix[4]={2,3,5,7};
int main()
{
    long long x;
    int i;
    result[0]=1;result[1]=1;
    for(i=0;i<4;i++)
    q.push(fix[i]);
    int u=2;
    while(!q.empty())
    {
        long long t=q.top();
        q.pop();
        result[u++]=t;
        for(i=0;i<4;i++)
        {
            long long temp=t*fix[i];
            if(!mark[temp])
            {
                mark[temp]=1;
                q.push(temp);
            }
        }
        if(u>5843) break;
    }
    string sign;
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0) break;
        if(n%10==1&&n%100!=11)sign="st";
        else if(n%10==2&&n%100!=12)sign="nd";
        else if(n%10==3&&n%100!=13)sign="rd";
        else sign="th";
        printf("The %d%s humble number is %lld.\n",n,sign.c_str(),result[n]);
//c语言输出string类型的应该用s.c_str()
    }

    return 0;
}

DP思想的:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
int result[5844];
int min(int x,int y,int z,int u)
{
     x=x>y?y:x;
     x=x>z?z:x;
     x=x>u?u:x;
     return x;
}
int main()
{
    int a=1,b=1,c=1,d=1;
    result[0]=1;result[1]=1;
    for(int i=2;i<5843;i++)
    {
        result[i]=min(result[a]*2,result[b]*3,result[c]*5,result[d]*7);
        if(result[i]==result[a]*2) a++;
        if(result[i]==result[b]*3) b++;
        if(result[i]==result[c]*5) c++;
        if(result[i]==result[d]*7) d++;
    }
    string sign;
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0) break;
        if(n%10==1&&n%100!=11)sign="st";
        else if(n%10==2&&n%100!=12)sign="nd";
        else if(n%10==3&&n%100!=13)sign="rd";
        else sign="th";
        printf("The %d%s humble number is %d.\n",n,sign.c_str(),result[n]);
    }

    return 0;
}

 

抱歉!评论已关闭.