现在的位置: 首页 > 综合 > 正文

hdu 1217 Arbitrage

2018年04月26日 ⁄ 综合 ⁄ 共 2495字 ⁄ 字号 评论关闭

相当于求最大路径,用到了map映射

Problem Description
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys
10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input
The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within
a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name
cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input
3 USDollar BritishPound FrenchFranc 3 USDollar 0.5 BritishPound BritishPound 10.0 FrenchFranc FrenchFranc 0.21 USDollar 3 USDollar BritishPound FrenchFranc 6 USDollar 0.5 BritishPound USDollar 4.9 FrenchFranc BritishPound 10.0 FrenchFranc BritishPound 1.99 USDollar FrenchFranc 0.09 BritishPound FrenchFranc 0.19 USDollar 0

Sample Output
Case 1: Yes
Case 2: No
 
#include<iostream>
#include<cstring>
#include<algorithm>
#include<queue>
#include<map>
using namespace std;
map<string,int>in;
int n,m,mark[31];
double mapp[31][31];
double dis[31];
int spfa(int s)
{
    int i;
    queue<int>q;
    memset(mark,0,sizeof(mark));
    memset(dis,0,sizeof(dis));
    mark[s]=1;
    dis[s]=1.0;
    q.push(s);
    while(!q.empty())
    {
        int first=q.front();
        q.pop();
        mark[first]=0;
        for(i=1;i<=n;i++)
        {
            if(dis[first]*mapp[first][i]>dis[i])
            {
                dis[i]=dis[first]*mapp[first][i];
                if(!mark[i])
                {
                    mark[i]=1;
                    q.push(i);
                }
                if(dis[s]>1)//注意这里要对每个点进行查找,当该点的最大路径比1大时返回,这里是s不是first      
                return 1;
            }

        }
    }

    return 0;
}
int main()
{
    int i,j,flag1=0;
    while(scanf("%d",&n)&&n)
    {
       flag1++;
       for(i=1;i<=n;i++)
       {
           for(j=1;j<=n;j++)
           {
               mapp[i][j]=(i==j?1.0:0);
           }
       }
       for(i=1;i<=n;i++)
       {
           char exm[50];
           scanf("%s",exm);
           in[exm]=i;
       }
       scanf("%d",&m);
       while(m--)
       {
           char char1[50],char2[50];
           double x;
           scanf("%s %lf %s",char1,&x,char2);
           mapp[in[char1]][in[char2]]=x;
       }
       int flag=0;
       for(i=1;i<=n;i++)
       {
          if(spfa(i))
          {
              flag=1;
              printf("Case %d: Yes\n",flag1);
              break;
          }
       }
       if(flag==0)
       printf("Case %d: No\n",flag1);
    }
    return 0;
}

抱歉!评论已关闭.