现在的位置: 首页 > 综合 > 正文

POJ 2000 Gold Coins(简单模拟)

2018年04月28日 ⁄ 综合 ⁄ 共 1825字 ⁄ 字号 评论关闭

好久没来写题了,有很多原因,不多说了, 现在抓紧时间来开始刷题就行了。。。

Gold Coins
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 21467   Accepted: 13457

Description

The king pays his loyal knight in gold coins. On the first day of his service, the knight receives one gold coin. On each of the next two days (the second and third days of service), the knight receives two gold coins. On each
of the next three days (the fourth, fifth, and sixth days of service), the knight receives three gold coins. On each of the next four days (the seventh, eighth, ninth, and tenth days of service), the knight receives four gold coins. This pattern of payments
will continue indefinitely: after receiving N gold coins on each of N consecutive days, the knight will receive N+1 gold coins on each of the next N+1 consecutive days, where N is any positive integer.

Your program will determine the total number of gold coins paid to the knight in any given number of days (starting from Day 1).

Input

The input contains at least one, but no more than 21 lines. Each line of the input file (except the last one) contains data for one test case of the problem, consisting of exactly one integer (in the range 1..10000), representing
the number of days. The end of the input is signaled by a line containing the number 0.

Output

There is exactly one line of output for each test case. This line contains the number of days from the corresponding line of input, followed by one blank space and the total number of gold coins paid to the knight in the given
number of days, starting with Day 1.

Sample Input

10
6
7
11
15
16
100
10000
1000
21
22
0

Sample Output

10 30
6 14
7 18
11 35
15 55
16 61
100 945
10000 942820
1000 29820
21 91
22 98

Source

解题思路:

POJ 2000 简单的一道模拟题,只要加,判断sum>=n,就结束,然后记录上一个阶段的状态,用sum+=i*i,把他们联系起来,完事后,把那些属于第j个阶段的数字在

补上就行了。。可以说很水了、

代码:

# include<cstdio>
# include<iostream>

using namespace std;

int main(void)
{
    int n;
    while ( cin>>n )
        {
            long long ans = 0;
            int sum = 0;

        if ( n == 0 )
            break;

        int j;
        for ( int i = 1;i <= n;i++ )
            {
                sum+=i;
                if ( n <= sum )
                    {
                        j = i-1;
                        break;
                    }
            }
        //cout<<j<<endl;
        for ( int i = 1;i <= j;i++ )
            {
                ans+=i*i;
            }
            int t = 0;

            for ( int i = 1;i <= j;i++ )
                {
                    t+=i;
                }
                        ans+=(n-t)*(j+1);
                    printf("%d %ld\n",n,ans);
        }


    return 0;
}

【上篇】
【下篇】

抱歉!评论已关闭.