现在的位置: 首页 > 综合 > 正文

POJ-1007:DNA Sorting

2018年04月29日 ⁄ 综合 ⁄ 共 2068字 ⁄ 字号 评论关闭

1007:DNA Sorting

时间限制: 
1000ms 
内存限制: 
65536kB
描述
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is
greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can
be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''.
All the strings are of the same length.

输入
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
输出
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
样例输入
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT
样例输出
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

题目的本质是计算逆序数,然后根据逆序数,对DNA序列进行排序
#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;



int main()
{
	/* recept the parameters */
	int length = 0;
	int n = 0;
	cin>>length;
	cin>>n;

	char **DNASeq = new char* [n];
	for(int i=0; i<n; ++i)
	{	
		DNASeq[i] = new char[length];
		cin>>DNASeq[i];		
	}
	

	/* calculate the number of inversions */
	int *inversions = new int [n];
	for(int i=0; i<n; ++i)
	{	
		inversions[i] = 0; /* initiate the array of inversion number */

		for(int j=0; j<length; ++j)
			for(int k=j+1; k<length; ++k)
				if( DNASeq[i][j]>DNASeq[i][k])
					inversions[i]++;
				
	}

	/*Bubble sort*/
	for(int i=0; i<n; ++i)
		for(int j=n-1; j>i; --j)
			if( inversions[j] < inversions[j-1])
			{
				int temp        = inversions[j];    /*swap*/
				inversions[j]   = inversions[j-1];
				inversions[j-1] = temp;

				char *tmp   = DNASeq[j];
				DNASeq[j]   = DNASeq[j-1];
				DNASeq[j-1] = tmp;
			}
	

	/*OUTPUT*/
	for(int i=0; i<n; ++i)
	{	cout<<DNASeq[i]<<endl;	}
	

	return 0;
}

排序部分为简洁,使用的是冒泡排序,也可将 DNA序列 和 逆序值 做成一个数据结构,然后用STL的sort排序,应该可以更加简洁。

抱歉!评论已关闭.