现在的位置: 首页 > 综合 > 正文

HDU 1299 Diophantus of Alexandria 求因子个数

2018年05月02日 ⁄ 综合 ⁄ 共 2399字 ⁄ 字号 评论关闭

Diophantus of Alexandria

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2447    Accepted Submission(s): 937

Problem Description
Diophantus of Alexandria was an egypt mathematician living in Alexandria. He was one of the first mathematicians to study equations where variables were restricted to integral values. In honor of him, these equations are commonly
called diophantine equations. One of the most famous diophantine equation is x^n + y^n = z^n. Fermat suggested that for n > 2, there are no solutions with positive integral values for x, y and z. A proof of this theorem (called Fermat's last theorem) was found
only recently by Andrew Wiles.

Consider the following diophantine equation:

1 / x + 1 / y = 1 / n where x, y, n ∈ N+ (1)

Diophantus is interested in the following question: for a given n, how many distinct solutions (i. e., solutions satisfying x ≤ y) does equation (1) have? For example, for n = 4, there are exactly three distinct solutions:

1 / 5 + 1 / 20 = 1 / 4
1 / 6 + 1 / 12 = 1 / 4
1 / 8 + 1 / 8 = 1 / 4

Clearly, enumerating these solutions can become tedious for bigger values of n. Can you help Diophantus compute the number of distinct solutions for big values of n quickly?

 

Input
The first line contains the number of scenarios. Each scenario consists of one line containing a single number n (1 ≤ n ≤ 10^9).
 

Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Next, print a single line with the number of distinct solutions of equation (1) for the given value of
n. Terminate each scenario with a blank line.
 

Sample Input
2 4 1260
 

Sample Output
Scenario #1: 3 Scenario #2: 113
/*
HDOJ 1299 求因子个数 
	定理1: 一个正整数n可以用素因子唯一表示为 p1^r1 * p2^r2 * ... pk^rk (其中pi为素数)
那么这个数的因子的个数就是,(r1+1)*(r2+1)~(rk+1).
	定理2:如果一个数字n= p1^r1 * p2^r2 * ... pk^rk那么n*n=p1^r1*p2^r2* ... pk^rk*p1^r1*p2^r2*... pk^rk
它的因子的个数就是(2*r1+1)*(2*r2+1)~(2*rk+1).
	1/x+1/y=1/n的x,y的组数,又因为x,y一定大于n 。所以设y=n+k(k为正整数);
带入方程得:x=n*n/k+n ;由于x是正整数,n*n/k有多少组正整数的可能
又因为n一定大于k,所以转换成求n*n的分解数;
*/
#include<iostream>
#include<stdio.h>
#include<math.h>
using namespace std;
#define N 40000

int isPrime[N],prime[N];
int main()
{
	int i,j,k,t,cas,n,ans,sq,num;
	//10^9 开根号 <10^5	
	memset(isPrime,0,sizeof(isPrime));//筛选素数 初始化全是素数 
	for(i=2;i<N;i++)
		if(!isPrime[i])//素数 
		{
			for(j=i*i;j<N;j+=i)  
          		isPrime[j]=1;  
		} 
	k=0;
	for(i=2;i<N;i++)
		if(!isPrime[i]) 
			prime[k++]=i;
			
	scanf("%d",&t);
	cas=1;
	while(t--)
	{		
		scanf("%d",&n);
		ans=1;
		sq=sqrt(double(n));
		for(i=0;i<k;i++)
		{
			num=0;
			if(prime[i]>sq)
				break;
			while(n%prime[i]==0)
			{
				n/=prime[i];
				num++;
			}
			ans*=(num*2+1);
		}
		if(n>1)
			ans*=3;//因为分解到最后可能是素数,但是不能继续分解了,所以还要加次
					//ans*=(num*2+1); num=1; 
		printf("Scenario #%d:\n%d\n\n",cas++,(ans+1)/2);//两两配对,有一对一定是相同的
	}
	return 0;
} 

抱歉!评论已关闭.