现在的位置: 首页 > 综合 > 正文

HDU 1238 Substrings

2018年05月02日 ⁄ 综合 ⁄ 共 1397字 ⁄ 字号 评论关闭

Substrings

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7699    Accepted Submission(s): 3474

Problem Description
You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.
Input
The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the
number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string. 
Output
There should be one line per test case containing the length of the largest string found.
Sample Input
2 3 ABCD BCDFF BRCD 2 rose orchid
Sample Output
2 2
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
#define N 101
char a[N][N];
int main()
{
	int t,n,min,k,i,j,len,pos,z,f,ans;
//	freopen("text.txt","r",stdin);
	scanf("%d",&t);getchar();
	while(t--)
	{
		scanf("%d",&n);
		min=101;
		for(i=0;i<n;i++)
		{
			scanf("%s",a[i]);
			len=strlen(a[i]);
			if(len<min)
			{
				min=len;
				pos=i;
			}
		}
		len=min;
		char str1[N],str2[N];
		ans=0;
		for(i=0;i<len;i++)
		{
			for(j=i;j<len;j++)
			{
				z=0;
				for(k=i;k<=j;k++)
				{
					str1[z++]=a[pos][k];
					str2[j-k]=a[pos][k];
				}
				str1[z]='\0';
				str2[j-i+1]='\0';
				f=1; 
				for(k=0;k<n;k++)
				{
					if(!strstr(a[k],str1)&&!strstr(a[k],str2))
					{
						f=0;
						break;
					}
				}
				k=strlen(str1);
				if(f==1&&ans<k)
				{
					ans=k;	
				}
			}
		}
		printf("%d\n",ans);
	} 
	return 0;
} 

抱歉!评论已关闭.