现在的位置: 首页 > 算法 > 正文

poj3278Catch That Cow(BFS)

2018年12月20日 算法 ⁄ 共 1526字 ⁄ 字号 评论关闭
Catch That Cow
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 37094   Accepted: 11466

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number
line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
刚做的时候发生了很多奇异YY, 搞的我不知道重写了多少遍。。大哭
从当前位置local,向local+1, local-1, local*2这三个方向扩展。
code:
#include <queue>
#include <cstdio>
#include<cstring>
#define N 100001
using namespace std;
int n, k, ans;
bool vis[N];
struct node {
    int local, time;
};
void bfs() {
    int t, i;
    node now, tmp;
    queue<node> q;
    now.local = n;
    now.time = 0;
    q.push(now);
    memset(vis,false,sizeof(vis));
    vis[now.local] = true;
    while(!q.empty()) {
        now = q.front();
        q.pop();
        for(i=0; i<3; i++) {
            if(0==i) t = now.local-1;
            else if(1==i) t = now.local+1;
            else if(2==i) t = now.local*2;
            if(t<0||t>N||vis[t]) continue;
            if(t==k) {
                ans = now.time+1;
                return;
            }
            vis[t] = true;
            tmp.local = t;
            tmp.time = now.time+1;
            q.push(tmp);
        }
    }
}

int main() {
    while(~scanf("%d%d",&n,&k)) {
        if(n>=k) printf("%d\n",n-k);
        else {
            bfs();
            printf("%d\n",ans);
        }
    }
}


抱歉!评论已关闭.