现在的位置: 首页 > 综合 > 正文

hdu1045—Fire Net

2019年02月14日 ⁄ 综合 ⁄ 共 3646字 ⁄ 字号 评论关闭

Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a ‘.’ indicating an open space and an uppercase ‘X’ indicating a wall. There are no spaces in the input file.

Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample Input

4 .X.. …. XX.. …. 2 XX .X 3 .X. X.X .X. 3 … .XX .XX 4 …. …. …. …. 0

Sample Output

5 1 5 2 4

Source
Zhejiang University Local Contest 2001

Recommend
We have carefully selected several similar problems for you: 1050 1175 1067 1258 1053

按行按列缩点(中间没有墙隔开的点)
然后对于每一个’.’,从它所在的行点的向列点建图,求最大匹配

/*************************************************************************
    > File Name: hdu1045.cpp
    > Author: ALex
    > Mail: zchao1995@gmail.com 
    > Created Time: 2015年02月16日 星期一 12时21分20秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

const double pi = acos(-1);
const int inf = 0x3f3f3f3f;
const double eps = 1e-15;
typedef long long LL;
typedef pair <int, int> PLL;

const int N = 20;
int edge[N][N];
int match[N];
bool used[N];
int un, vn;
int row[10][10];
int col[10][10];
char mat[10][10];

bool dfs (int u)
{
    for (int i = 0; i < vn; ++i)
    {
        if (!used[i] && edge[u][i])
        {
            used[i] = 1;
            if (match[i] == -1 || dfs (match[i]))
            {
                match[i] = u;
                return 1;
            }
        }
    }
    return 0;
}

int hungry ()
{
    int ans = 0;
    memset (match, -1, sizeof(match));
    for (int i = 0; i < un; ++i)
    {
        memset (used, 0, sizeof(used));
        if (dfs (i))
        {
            ++ans;
        }
    }
    return ans;
}

int main ()
{
    int n;
    while (~scanf("%d", &n), n)
    {
        memset (edge, 0, sizeof(edge));
        for (int i = 0; i < n; ++i)
        {
            scanf("%s", mat[i]);
        }
        un = 0;
        for (int i = 0; i < n; ++i)
        {
            int j = 0;
            bool flag = false;
            while (j < n)
            {
                if (mat[i][j] == '.')
                {
                    flag = true;
                    row[i][j] = un;
                    ++j;
                    if (j == n)
                    {
                        ++un;
                    }
                }
                else
                {
                    ++j;
                    if (flag)
                    {
                        ++un;
                    }
                }
            }
        }
        vn = 0;
        for (int j = 0; j < n; ++j)
        {
            int i = 0;
            bool flag = false;
            while (i < n)
            {
                if (mat[i][j] == '.')
                {
                    flag = true;
                    col[i][j] = vn;
                    ++i;
                    if (i == n)
                    {
                        ++vn;
                    }
                }
                else
                {
                    ++i;
                    if (flag)
                    {
                        ++vn;
                    }
                }
            }
        }
        for (int i = 0; i < n; ++i)
        {
            for (int j = 0; j < n; ++j)
            {
                if (mat[i][j] == '.')
                {
                    edge[row[i][j]][col[i][j]] = 1;
                }
            }
        }
        int res = hungry();
        printf("%d\n", res);
    }
    return 0;
}

抱歉!评论已关闭.