现在的位置: 首页 > 综合 > 正文

hdu——4463Outlets

2019年02月15日 ⁄ 综合 ⁄ 共 2844字 ⁄ 字号 评论关闭
Problem Description
In
China, foreign brand commodities are often much more expensive than
abroad. The main reason is that we Chinese people tend to think foreign
things are better and we are willing to pay much for them. The typical
example is, on the United Airline flight, they give you Haagendazs ice
cream for free, but in China, you will pay $10 to buy just a little cup.
So
when we Chinese go abroad, one of our most favorite activities is
shopping in outlets. Some people buy tens of famous brand shoes and bags
one time. In Las Vegas, the existing outlets can't match the demand of
Chinese. So they want to build a new outlets in the desert. The new
outlets consists of many stores. All stores are connected by roads. They
want to minimize the total road length. The owner of the outlets just
hired a data mining expert, and the expert told him that Nike store and
Apple store must be directly connected by a road. Now please help him
figure out how to minimize the total road length under this condition. A
store can be considered as a point and a road is a line segment
connecting two stores.
 

Input
There
are several test cases. For each test case: The first line is an
integer N( 3 <= N <= 50) , meaning there are N stores in the
outlets. These N stores are numbered from 1 to N. The second line
contains two integers p and q, indicating that the No. p store is a Nike
store and the No. q store is an Apple store. Then N lines follow. The
i-th line describes the position of the i-th store. The store position
is represented by two integers x,y( -100<= x,y <= 100) , meaning
that the coordinate of the store is (x,y). These N stores are all
located at different place. The input ends by N = 0.
 

Output
For each test case, print the minimum total road length. The result should be rounded to 2 digits after decimal point.
 

Sample Input
4 2 3 0 0 1 0 0 -1 1 -1 0
 

Sample Output
3.41
 

Source
2012 Asia Hangzhou Regional Contest

最小生成树稍微变形一下,但还是题水题。
把那条必选的边的权值先改成0就行了。

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#include<map>
#include<set>
#include<vector>

using namespace std;

struct node
{
int from,to;
double weight;
}edge[10010];

struct point
{
int x,y;
}list[100];

double dis(int x1,int y1,int x2,int y2)
{
return sqrt((double)((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2)));
}

int cmp(node a,node b)
{
return a.weight < b.weight;
}

int father[100];

void unit(int n)
{
for(int i=0;i<=n;i++)
father[i]=i;
}

int find(int x)
{
if(x!=father[x])
father[x]=find(father[x]);
return father[x];
}

void merge(int a,int b)
{
int aa=find(a);
int bb=find(b);
if(aa!=bb)
father[aa]=bb;
}

double kruskal(int n,int v,int p,int q)//t是必选的那条边 ,n是边的个数
{
unit(v);//并查集初始化,v是点的个数
sort(edge,edge+n,cmp);
int m=0;
double sum=dis(list[p].x,list[p].y,list[q].x,list[q].y);
for(int i=0;i<n;i++)
{
int a=find(edge[i].from);
int b=find(edge[i].to);
if(a!=b)
{
merge(a,b);
sum+=edge[i].weight;
m++;
}
if(m==v-1)
break;
}
return sum;
}

int main()
{
int n;
while(~scanf("%d",&n) && n)
{
int p,q,cnt=0;
scanf("%d%d",&p,&q);
for(int i=1;i<=n;i++)
scanf("%d%d",&list[i].x,&list[i].y);
for(int i=1;i<=n;i++)
for(int j=i+1;j<=n;j++)
{

edge[cnt].from=i;
edge[cnt].to=j;
edge[cnt].weight=dis(list[i].x,list[i].y,list[j].x,list[j].y);
if((i==p && j==q) || (i==q && j==p))
edge[cnt].weight=0;
cnt++;
}
printf("%.2f\n",kruskal(cnt,n,p,q));
}
return 0;
}

抱歉!评论已关闭.