现在的位置: 首页 > 综合 > 正文

POJ3164—Command Network

2019年02月16日 ⁄ 综合 ⁄ 共 3425字 ⁄ 字号 评论关闭
Command Network
Time Limit: 1000MS   Memory Limit: 131072K
Total Submissions: 13609   Accepted: 3925

Description

After a long lasting war on words, a war on arms finally breaks out between littleken’s and KnuthOcean’s kingdoms. A sudden and violent assault by KnuthOcean’s force has rendered a total failure of littleken’s command network. A provisional network must
be built immediately. littleken orders snoopy to take charge of the project.

With the situation studied to every detail, snoopy believes that the most urgent point is to enable littenken’s commands to reach every disconnected node in the destroyed network and decides on a plan to build a unidirectional communication network. The
nodes are distributed on a plane. If littleken’s commands are to be able to be delivered directly from a node A to another node B, a wire will have to be built along the straight line segment connecting the two nodes. Since it’s in wartime, not between all
pairs of nodes can wires be built. snoopy wants the plan to require the shortest total length of wires so that the construction can be done very soon.

Input

The input contains several test cases. Each test case starts with a line containing two integer
N (N ≤ 100), the number of nodes in the destroyed network, and
M
(M ≤ 104), the number of pairs of nodes between which a wire can be built. The next
N lines each contain an ordered pair xi and yi, giving the Cartesian coordinates of the nodes. Then follow
M lines each containing two integers i and j between 1 and
N (inclusive) meaning a wire can be built between node i and node
j for unidirectional command delivery from the former to the latter. littleken’s headquarter is always located at node 1. Process to end of file.

Output

For each test case, output exactly one line containing the shortest total length of wires to two digits past the decimal point. In the cases that such a network does not exist, just output ‘poor snoopy’.

Sample Input

4 6
0 6
4 6
0 0
7 20
1 2
1 3
2 3
3 4
3 1
3 2
4 3
0 0
1 0
0 1
1 2
1 3
4 1
2 3

Sample Output

31.19
poor snoopy

Source

POJ Monthly--2006.12.31, galaxy

最小树形图,裸题

/*************************************************************************
    > File Name: poj3164.cpp
    > Author: ALex
    > Mail: 405045132@qq.com 
    > Created Time: 2015年01月26日 星期一 14时25分48秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int N = 110;
const int inf = 0x3f3f3f3f;

struct node
{
	int u, v;
	double w;
}edge[N * N];

struct Point
{
	int x, y;
}point[N];

int pre[N], vis[N], id[N];
double in[N];

double zhuliu (int root, int n, int m)
{
	double res = 0;
	int u, v;
	while (1)
	{
		for (int i = 0; i < n; ++i)
		{
			in[i] = (double)inf;
		}
		for (int i = 0; i < m; ++i)
		{
			if (edge[i].u != edge[i].v && edge[i].w < in[edge[i].v])
			{
				in[edge[i].v] = edge[i].w;
				pre[edge[i].v] = edge[i].u;
			}
		}
		for (int i = 0; i < n; ++i)
		{
			if (i != root && in[i] == inf)
			{
				return -1;
			}
		}
		int tn = 0;
		memset (id, -1, sizeof (id));
		memset (vis, -1, sizeof(vis));
		in[root] = 0;
		for (int i = 0; i < n; ++i)
		{
			res += in[i];
			v = i;
			while (vis[v] != i && id[v] == -1 && v != root)
			{
				vis[v] = i;
				v = pre[v];
			}
			if (v != root && id[v] == -1)
			{
				for (int u = pre[v]; u != v; u = pre[u])
				{
					id[u] = tn;
				}
				id[v] = tn++;
			}
		}
		if (tn == 0)
		{
			break;
		}
		for (int i = 0; i < n; ++i)
		{
			if (id[i] == -1)
			{
				id[i] = tn++;
			}
		}
		for (int i = 0; i < m; ++i)
		{
			v = edge[i].v;
			edge[i].u = id[edge[i].u];
			edge[i].v = id[edge[i].v];
			if (edge[i].u != edge[i].v)
			{
				edge[i].w -= in[v];
			}
		}
		n = tn;
		root = id[root];
	}
	return res;
}

double dist (Point a, Point b)
{
	int x = a.x - b.x;
	int y = a.y - b.y;
	return sqrt (double (x * x + y * y));
}

int main ()
{
	int n, m;
	int u, v;
	while (~scanf("%d%d", &n, &m))
	{
		for (int i = 0; i < n; ++i)
		{
			scanf("%d%d", &point[i].x, &point[i].y);
		}
		for (int i = 0; i < m; ++i)
		{
			scanf("%d%d", &u, &v);
			--u;
			--v;
			edge[i].u = u;
			edge[i].v = v;
			edge[i].w = dist (point[u], point[v]);
		}
		double ans = zhuliu (0, n, m);
		if (ans == -1)
		{
			printf("poor snoopy\n");
		}
		else
		{
			printf("%.2f\n", ans);
		}
	}
	return 0;
}

抱歉!评论已关闭.