现在的位置: 首页 > 综合 > 正文

POJ1836——Alignment

2019年02月18日 ⁄ 综合 ⁄ 共 2113字 ⁄ 字号 评论关闭
Alignment
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 13366   Accepted: 4296

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true
that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but
getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between
him and that extremity.

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line.

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this
line represents the height of the soldier who has the code k (1 <= k <= n).

There are some restrictions:
• 2 <= n <= 1000
• the height are floating numbers from the interval [0.5, 2.5]

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4

Source

Romania OI 2002

题目不难,就是让你踢掉最少的人,使得剩下的序列先增后减,那么只要往左求一次LIS,往右求一次LIS就行了,关键是细节处理很麻烦,我一开始枚举中间点的时候认为他们的分界点一定是一个(也就是连在一起的),其实可以中间也断开

#include <map>  
#include <set>  
#include <list>  
#include <stack>  
#include <vector>  
#include <queue>  
#include <cmath>  
#include <cstdio>  
#include <cstring>  
#include <iostream>  
#include <algorithm>  

using namespace std;

const int N = 1010;

int LMaxS[N], LMinS[N];
double subsence[N];

int main()
{
	int n;
	while (~scanf("%d", &n))
	{
		for (int i = 1; i <= n; ++i)
		{
			scanf("%lf", &subsence[i]);
			LMaxS[i] = 1;
			LMinS[i] = 1;
		}
		for (int i = 2; i <= n; ++i)
		{
			for (int j = 1; j < i; ++j)
			{
				if (subsence[i] > subsence[j]  && LMaxS[i] < LMaxS[j] + 1)
				{
					LMaxS[i] = LMaxS[j] + 1;
				}
			}
		}
		for (int i = n - 1; i >= 1; --i)
		{
			for (int j = n; j > i; --j)
			{
				if (subsence[i] > subsence[j] && LMinS[i] < LMinS[j] + 1)
				{
					LMinS[i] = LMinS[j] + 1;
				}
			}
		}
		int ans = 0;
		for (int i = 1; i <= n; ++i)
		{
			for (int j = i + 1; j <= n; ++j)
			{
				ans = max(ans, LMaxS[i] + LMinS[j]);
			}
		}
		printf("%d\n", n - ans);
	}
	return 0;
}
【上篇】
【下篇】

抱歉!评论已关闭.