现在的位置: 首页 > 算法 > 正文

poj2955Brackets(区间DP)

2019年02月21日 算法 ⁄ 共 1754字 ⁄ 字号 评论关闭

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such
that for indices i1i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is
a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive.
The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6
dp[i][j]表示在区间i到j匹配的最大数。
#include<stdio.h>
#include<string.h>
int max(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    int dp[105][105];
    char str[105];
    while(scanf("%s",str)>0&&strcmp(str,"end")!=0)
    {
        int len=strlen(str);
        memset(dp,0,sizeof(dp));
        for(int l=1;l<len;l++)//所求区间头尾相差长度
        for(int i=0;i<len-l;i++)//区间起始位置
        {
            int j=l+i;//区间尾部位置
            dp[i][j]=dp[i+1][j];//当第i个在这段区间内没有匹配的时
            for(int k=i+1;k<=j;k++)//当第i个与第k个位置匹配上时,状态转移如下
            if(str[i]=='('&&str[k]==')'||str[i]=='['&&str[k]==']')
            dp[i][j]=max(dp[i][j],dp[i+1][k-1]+dp[k+1][j]+2);
        }
        printf("%d\n",dp[0][len-1]);
    }
}

抱歉!评论已关闭.