现在的位置: 首页 > 算法 > 正文

poj 1364

2019年02月28日 算法 ⁄ 共 4178字 ⁄ 字号 评论关闭
King
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 8777   Accepted: 3305

Description

Once, in one kingdom, there was a queen and that queen was expecting a baby. The queen prayed: ``If my child was a son and if only he was a sound king.'' After nine months her child was born, and indeed, she gave birth to a nice son. 
Unfortunately, as it used to happen in royal families, the son was a little retarded. After many years of study he was able just to add integer numbers and to compare whether the result is greater or less than a given integer number. In addition, the numbers
had to be written in a sequence and he was able to sum just continuous subsequences of the sequence. 

The old king was very unhappy of his son. But he was ready to make everything to enable his son to govern the kingdom after his death. With regards to his son's skills he decided that every problem the king had to decide about had to be presented in a form
of a finite sequence of integer numbers and the decision about it would be done by stating an integer constraint (i.e. an upper or lower limit) for the sum of that sequence. In this way there was at least some hope that his son would be able to make some decisions. 

After the old king died, the young king began to reign. But very soon, a lot of people became very unsatisfied with his decisions and decided to dethrone him. They tried to do it by proving that his decisions were wrong. 

Therefore some conspirators presented to the young king a set of problems that he had to decide about. The set of problems was in the form of subsequences Si = {aSi, aSi+1, ..., aSi+ni} of a sequence S = {a1, a2, ..., an}. The king thought a minute and then
decided, i.e. he set for the sum aSi + aSi+1 + ... + aSi+ni of each subsequence Si an integer constraint ki (i.e. aSi + aSi+1 + ... + aSi+ni < ki or aSi + aSi+1 + ... + aSi+ni > ki resp.) and declared these constraints as his decisions. 

After a while he realized that some of his decisions were wrong. He could not revoke the declared constraints but trying to save himself he decided to fake the sequence that he was given. He ordered to his advisors to find such a sequence S that would satisfy
the constraints he set. Help the advisors of the king and write a program that decides whether such a sequence exists or not. 

Input

The input consists of blocks of lines. Each block except the last corresponds to one set of problems and king's decisions about them. In the first line of the block there are integers n, and m where 0 < n <= 100 is length of the sequence S and 0 < m <= 100
is the number of subsequences Si. Next m lines contain particular decisions coded in the form of quadruples si, ni, oi, ki, where oi represents operator > (coded as gt) or operator < (coded as lt) respectively. The symbols si, ni and ki have the meaning described
above. The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the blocks in the input. A line contains text successful conspiracy when such a sequence does not exist. Otherwise it contains text lamentable kingdom. There is no line in the output corresponding to the last ``null''
block of the input.

Sample Input

4 2
1 2 gt 0
2 2 lt 2
1 2
1 0 gt 0
1 0 lt 0
0

Sample Output

lamentable kingdom
successful conspiracy

Source

题目真的很难懂,读了好久好久好久好久~~~~~~~~~
题意及思路:可以这样理解,有一个序列a1,a2,a3、、、、、、an;前n项和为sn;这里拿第一组样例来讲吧,第一行4 2,代表a序列有4项,接下来跟2行关系式,1 2 gt 0代表从第一项及之后两项的和大于0,即a1a2a3的和大于0,下一行2 2 lt 2代表第二项及之后2项的和小于2。如果存在数列a符合这样的条件输出lamentable kingdom,否则输出successful conspiracy。这样,你得到的俩个不等式
a1+a2+a3>0
a2+a3+a4<2
这里可以用前n项和表示成
s3-s0>0
s4-s1<2
因为a是整数序列,所以又可以写成
s3-s0>=1
s4-s1<=1
这样就转化成了差分约束的问题,判断a序列是否存在变成了判断s序列是否存在
由于这里会使用到s0,所以我们做差分约束添加源点的时候不能用0咯,用n+1吧。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
struct Edge
{
    int a,b,c;
}e[10005];
int fst[1005];
int next[10005];
int cnt[10005];
bool v[10005];
int dist[10005];
int m,n,a,b,c;
char ss[10];
bool spfa()
{
    memset(cnt,0,sizeof(cnt));
    memset(v,0,sizeof(v));
    for(int i=0;i<=n+1;i++)dist[i]=1;
    dist[n+1]=0;
    queue<int >q;
    q.push(n+1);
    v[n+1]=1;
    cnt[n+1]++;
    while(!q.empty())
    {
        a=q.front();
        q.pop();
        v[a]=0;
        for(int i=fst[a];i!=-1;i=next[i])
        {
            b=e[i].b;
            c=e[i].c;
            if(dist[b]>dist[a]+e[i].c)
            {
                dist[b]=dist[a]+e[i].c;
                if(!v[b])
                {
                    q.push(b);
                    v[b]=1;
                    cnt[b]++;
                    if(cnt[b]>n)return false;
                }
            }
        }
    }
    return true;
}
int main()
{
    int num;
    while(scanf("%d",&n)&&n)
    {
        num=0;
        memset(fst,-1,sizeof(fst));
        scanf("%d",&m);
        for(int i=0;i<m;i++)
        {
            scanf("%d%d %s %d",&a,&b,&ss,&c);
            if(ss[0]=='g')
            {
                c++;
                next[num]=fst[a+b];
                fst[a+b]=num;
                e[num].a=a+b;
                e[num].b=a-1;
                e[num++].c=-c;
            }
            else
            {
                c--;
                next[num]=fst[a-1];
                fst[a-1]=num;
                e[num].a=a-1;
                e[num].b=a+b;
                e[num++].c=c;
            }
        }
        for(int i=1;i<=n;i++)
        {
            next[num]=fst[n+1];
            fst[n+1]=num;
            e[num].a=n+1;
            e[num].b=i;
            e[num++].c=0;
        }
        if(spfa())cout<<"lamentable kingdom"<<endl;
        else cout<<"successful conspiracy"<<endl;
    }
    return 0;
}
【上篇】
【下篇】

抱歉!评论已关闭.