现在的位置: 首页 > 算法 > 正文

poj 1837

2019年02月28日 算法 ⁄ 共 2547字 ⁄ 字号 评论关闭
Balance
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 8227   Accepted: 5000

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25.
Gigel may droop any weight of any hook but he is forced to use all the weights. 
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
It is guaranteed that will exist at least one solution for each test case at the evaluation. 

Input

The input has the following structure: 
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis
(when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the
hook is attached: '-' for the left arm and '+' for the right arm); 
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values. 

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2

Source

难得1A
题目大意:
就差不多一个杠杆,中间是0,有c个可以挂的位置,有g个重物,要问你有多少种挂法使它平衡。
这是一道dp题啊,想要列出所以情况的想法赶快抛抛掉。
下面给出思路:
平衡状态可以看作0为刚好平衡,挂1个重物,平衡状态可以表示为0+重量*挂的坐标。应为挂的坐标可以为负,所以我将mid设为刚好平衡的状态,在这个基础上来加减。
我设了一个数组f,f[i][j]表示第i个中午挂上后,平衡状态为的个数,大致如下转换
                if(f[i-1][j])
                {
                    for(int u=0;u<c;u++)//列举所有可以挂的地方,x数组为坐标
                    {
                        f[i][j+w*x[u]]+=f[i-1][j];
                    }
                }
这样,从头到尾来一遍后,f[g][mid]即为答案了。
#include<iostream>
#include<cstdio>
#include<cstring>
#define mid 8000
using namespace std;
int f[25][2*mid+100];
int c,g,ma,mi,x[25],w,mma,mmi;
int main()
{
    while(scanf("%d%d",&c,&g)!=EOF)
    {
        mi=mid;
        ma=mid;
        mma=ma;
        mmi=mi;
        memset(f,0,sizeof(f));
        f[0][mid]=1;
        for(int i=0;i<c;i++)scanf("%d",&x[i]);
        for(int i=1;i<=g;i++)
        {
            scanf("%d",&w);
            for(int j=mi;j<=ma;j++)
            {
                if(f[i-1][j])
                {
                    for(int u=0;u<c;u++)
                    {
                        f[i][j+w*x[u]]+=f[i-1][j];
                        if(j+w*x[u]>mma)mma=j+w*x[u];
                        if(j+w*x[u]<mmi)mmi=j+w*x[u];
                    }
                }
            }
            ma=mma;
            mi=mmi;
        }
        cout<<f[g][mid]<<endl;
    }
    return 0;
}
【上篇】
【下篇】

抱歉!评论已关闭.