现在的位置: 首页 > 算法 > 正文

poj 2565 Ants (KM+思维)

2019年04月13日 算法 ⁄ 共 3187字 ⁄ 字号 评论关闭
Ants
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 4125   Accepted: 1258   Special Judge

Description

Young naturalist Bill studies ants in school. His ants feed on plant-louses that live on apple trees. Each ant colony needs its own apple tree to feed itself.

Bill has a map with coordinates of n ant colonies and n apple trees. He knows that ants travel from their colony to their feeding places and back using chemically tagged routes. The routes cannot intersect each other or ants will get confused
and get to the wrong colony or tree, thus spurring a war between colonies.

Bill would like to connect each ant colony to a single apple tree so that all n routes are non-intersecting straight lines. In this problem such connection is always possible. Your task is to write a program that finds such connection.

On this picture ant colonies are denoted by empty circles and apple trees are denoted by filled circles. One possible connection is denoted by lines.

Input

The first line of the input file contains a single integer number n (1 ≤ n ≤ 100) — the number of ant colonies and apple trees. It is followed by n lines describing n ant colonies, followed by n lines describing n apple trees. Each ant
colony and apple tree is described by a pair of integer coordinates x and y (−10 000 ≤ xy ≤ 10 000) on a Cartesian plane. All ant colonies and apple trees occupy distinct points on a plane. No
three points are on the same line.

Output

Write to the output file n lines with one integer number on each line. The number written on i-th line denotes the number (from 1 to n) of the apple tree that is connected to the i-th ant colony.

Sample Input

5
-42 58
44 86
7 28
99 34
-13 -59
-47 -44
86 74
68 -75
-68 60
99 -60

Sample Output

4
2
1
5
3

Source

题意:

给你n个黑点和n个白点。叫你找出一种连点的方法使得每一白点连一个黑点。切连线不与其它连线相交。

思路:

看上去跟想几何问题跟KM没什么关系。但确实是KM题。求连线的最短距离就行了。因为在连线距离最小的条件下。不会有两条直线相交的情况。画个图就知道(三角形两边之和大于第三边)。需要稍稍的转换下。两点间的价值为距离的负数。还有特别注意答案要求输出每一个C对应的A。所以建边时要注意left[i]代表什么!鄙人就为这个WA了好几发。TT。

详细见代码:

#include<algorithm>
#include<iostream>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<math.h>
#include<vector>
#include<string>
#include<queue>
#include<set>
#include<map>
//#pragma comment(linker,"/STACK:1024000000,1024000000")
using namespace std;
const int INF=0x3f3f3f3f;
const double eps=1e-6;
const double PI=acos(-1.0);
const int maxn=110;
//typedef __int64 ll;
int le[maxn],n;
double lx[maxn],ly[maxn],slack[maxn],w[maxn][maxn],ax[maxn],ay[maxn],bx[maxn],by[maxn];
bool visx[maxn],visy[maxn];
double dist(double x1,double y1,double x2,double y2)
{
    double x=x1-x2,y=y1-y2;
    return sqrt(x*x+y*y);
}
bool match(int x)
{
    int y;
    double tp;
    visx[x]=true;
    for(y=1;y<=n;y++)
    {
        if(visy[y])
            continue;
        tp=lx[x]+ly[y]-w[x][y];
        if(tp<eps)
        {
            visy[y]=true;
            if(!le[y]||match(le[y]))
            {
                le[y]=x;
                return true;
            }
        }
        else
            slack[y]=min(slack[y],tp);
    }
    return false;
}
void update()
{
    int i;
    double d;

    for(i=1,d=INF;i<=n;i++)
        if(!visy[i])
            d=min(d,slack[i]);
    for(i=1;i<=n;i++)
    {
        if(visx[i])
            lx[i]-=d;
        if(visy[i])
            ly[i]+=d;
        else
            slack[i]-=d;
    }
}
void KM()
{
    int i,j,x;

    memset(le,0,sizeof le);
    for(i=1;i<=n;i++)
    {
        lx[i]=-INF;//注意这里!!
        ly[i]=0;
        for(j=1;j<=n;j++)
            lx[i]=max(lx[i],w[i][j]);
    }
    for(x=1;x<=n;x++)
    {
        for(i=1;i<=n;i++)
            slack[i]=INF;
        while(1)
        {
            for(i=1;i<=n;i++)
                visx[i]=visy[i]=false;
            if(match(x))
                break;
            else
                update();
        }
    }
}
int main()
{
    int i,j;

    while(~scanf("%d",&n))
    {
        for(i=1;i<=n;i++)
            scanf("%lf%lf",&ax[i],&ay[i]);
        for(i=1;i<=n;i++)
            scanf("%lf%lf",&bx[i],&by[i]);
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
                w[j][i]=-dist(ax[i],ay[i],bx[j],by[j]);//这里特别注意!由于答案输出的关系
        KM();
        for(i=1;i<=n;i++)
            printf("%d\n",le[i]);
    }
    return 0;
}

抱歉!评论已关闭.