现在的位置: 首页 > 算法 > 正文

poj 1050 To the Max(最大子矩阵权值)

2019年04月13日 算法 ⁄ 共 1943字 ⁄ 字号 评论关闭
To the Max
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 38220   Accepted: 20161

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the
sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines).
These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

Source

题意

给你一个数字矩阵。要你找出一个子矩阵。使得该矩阵的和比任意其它子矩阵的和都大。求出最大值。

思路:

对于一维的最大连续和肯定很简单。dp[i]=max(arr[i],dp[i-1]+arr[i])。dp[i]表示最大连续和包含arr[i]的最大值。

那么二维就推广下。枚举子矩阵的上下边。把两边间的数字压缩成一条线就可以按一维处理了。

详细见代码:

#include<algorithm>
#include<iostream>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<math.h>
#include<vector>
#include<string>
#include<queue>
#include<set>
#include<map>
//#pragma comment(linker,"/STACK:1024000000,1024000000")
using namespace std;
const int INF=0x3f3f3f3f;
const double eps=1e-8;
const double PI=acos(-1.0);
const int maxn=100010;
//typedef __int64 ll;
int sum[150][150],dp[150];
int main()
{
    int data,n,i,j,k,ans,tp;

    memset(sum,0,sizeof sum);
    dp[0]=0;
    while(~scanf("%d",&n))
    {
        ans=-INF;
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                scanf("%d",&data);
                sum[j][i]=sum[j][i-1]+data;
            }
        }
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=i;j++)
            {
                for(k=1;k<=n;k++)
                {
                    tp=sum[k][i]-sum[k][i-j-1];
                    dp[k]=max(tp,dp[k-1]+tp);
                    ans=max(dp[k],ans);
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

抱歉!评论已关闭.