现在的位置: 首页 > 算法 > 正文

poj2001Shortest Prefixes

2019年11月06日 算法 ⁄ 共 2435字 ⁄ 字号 评论关闭
Shortest Prefixes
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 14452   Accepted: 6230

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string
is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that
uniquely identifies the word it represents. 

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo". 

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list
that begins with "car". 

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

Source

Rocky Mountain 2004

找出能唯一标示一个字符串的最短前缀,如果找不出,就输出该字符串


心血来潮,想到刚开始学字典树的时候有一种静态数组实现的方法,当时还不太理解,


现在联系到向前星的写法,就想着大概是这个意思,于是写了一发试试


#include<map>
#include<string>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#include<bitset>
#include<climits>
#include<list>
#include<iomanip>
#include<stack>
#include<set>
using namespace std;
int tail;
struct Edge
{
	int next[26],cnt;
}edge[int(1e5)];
void add(string s)
{
	int k=0;
	for(int i=0;i<s.length();i++)
	{
		if(edge[k].next[s[i]-'a']==0)
			edge[k].next[s[i]-'a']=++tail;
		k=edge[k].next[s[i]-'a'];
		edge[k].cnt++;
	}
}
string seek(string s)
{
	int k=0;
	for(int i=0;i<s.length();i++)
	{
		k=edge[k].next[s[i]-'a'];
		if(edge[k].cnt==1)
			return s.substr(0,i+1);
	}
	return s;
}
int main()
{
	string s;
	vector<string>box;
	while(cin>>s)
	{
		add(s);
		box.push_back(s);
	}
	for(int i=0;i<box.size();i++)
		cout<<box[i]<<" "<<seek(box[i])<<endl;
}

抱歉!评论已关闭.