现在的位置: 首页 > 综合 > 正文

POJ 2186 Popular Cows 强连通分量+缩点

2014年04月05日 ⁄ 综合 ⁄ 共 2086字 ⁄ 字号 评论关闭

点击打开链接

 

 

Popular Cows
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 19297   Accepted: 7767

Description

Every cow's dream is to become the most popular cow in the herd.  In a herd of N (1 <= N <= 10,000) cows, you are given up to M (1 <= M <= 50,000) ordered pairs of the form (A, B) that tell you that cow A thinks that cow B is popular. 
Since popularity is transitive, if A thinks B is popular and B thinks C is popular, then A will also think that C is 

popular, even if this is not explicitly specified by an ordered pair in the input.  Your task is to compute the number of cows that are considered popular by every other cow.

Input

* Line 1: Two space-separated integers, N and M

* Lines 2..1+M: Two space-separated numbers A and B, meaning that A thinks B is popular.

Output

* Line 1: A single integer that is the number of cows who are considered popular by  every other cow.

Sample Input

3 3
1 2
2 1
2 3

Sample Output

1

Hint

Cow 3 is the only cow of high popularity.

Source

 

 

 

题意:有N只奶牛,其中奶牛A认为奶牛B备受注目,而奶牛B也可能认为奶牛C备受注目。奶牛们的这种“认为”是单向可传递的,就是说若奶牛A认为奶牛B备受注目,但奶牛B不一定会认为奶牛A备受注目。而当A认为B备受注目,且B认为C备受注目时,A一定也认为C备受注目。

思路:强连通+缩点.

 

#include <string.h>
#include <stdio.h>
using namespace std;
#define M 10010
int min(int a,int b)
{
    return a<b?a:b;
}
struct Edge
{
    int v,to;
} edge[5*M];
int head[M];
int edgeNum;
int cnt,scnt,begin,n,m;
int low[M],dfn[M],stack[M],id[M],out[M];
int ans[M];
void add(int a,int b)//建立邻接表
{
    edge[edgeNum].v=b;
    edge[edgeNum].to=head[a];
    head[a]=edgeNum++;
}
void dfs(int x)
{
    low[x]=dfn[x]=++cnt;
    stack[++begin]=x;
    int v;
    for(int i=head[x]; i!=-1; i=edge[i].to)
    {
        v=edge[i].v;
        if(!dfn[v])
        {
            dfs(v);
            low[x]=min(low[v],low[x]);
        }
        else if(!id[v])
        {
            low[x]=min(dfn[v],low[x]);
        }
    }
    if(low[x]==dfn[x])
    {
        scnt++;
        int tmp=0;
        do
        {
            tmp++;
            v=stack[begin--];
            id[v]=scnt;
        }
        while(v!=x);
        ans[scnt]=tmp;
    }
    return ;
}

int main()
{
    int a,b;
    while(scanf("%d%d",&n,&m)!=EOF)
    {

        edgeNum=cnt=scnt=begin=0;
        memset(id,0,sizeof(id));
        memset(head,-1,sizeof(head));
        memset(dfn,0,sizeof(dfn));
        for(int i=0; i<m; i++)
        {
            scanf("%d%d",&a,&b);
            add(a,b);
        }
        for(int i=1; i<=n; i++)
        {
            if(!dfn[i]) dfs(i);
         }
        if(scnt==1)
        {
            printf("%d\n",n);
            continue;
        }
        memset(out,0,sizeof(out));
        for(int i=1; i<=n; i++)
            for(int j=head[i]; j!=-1; j=edge[j].to)
            {
                int v=edge[j].v;
                if(id[i]!=id[v])
                {
                    out[id[i]]++;
                }
            }
        int res=0;
        for(int i=1; i<=scnt; i++)
        {
            if(!out[i])
            {
                if(!res) res=ans[i];
                else
                {
                    res=0;
                    break;
                }
            }
        }
        printf("%d\n",res);
    }
}

 

 

抱歉!评论已关闭.