现在的位置: 首页 > 综合 > 正文

HDU 1081 To The Max 求最大子矩阵

2014年04月05日 ⁄ 综合 ⁄ 共 1837字 ⁄ 字号 评论关闭

点击打开链接

 

 

To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6022    Accepted Submission(s): 2869

Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle.
In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.

 

 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace
(spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will
be in the range [-127,127].
 

 

Output
Output the sum of the maximal sub-rectangle.
 

 

Sample Input
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
 

 

Sample Output
15
 

 

Source
 

题目大意:给定一个含有正数和负数的矩阵,求其子矩阵的和的最大值。

一维的情况很简单,如何把一维的情况转化为二维情况呢?
例如,对于本题的测试数据:
我们可以每次任选几行,压缩成一行,这样就转化为了一维情况。
例如,我们求1~2行中的最大子矩阵:即矩阵高为2(1~2行),宽为1:4的矩阵,可以先把1~2行相加,得到9 0 -13 2,再求这个单行的最大子段,由此就可以求得1~2行的最大子矩阵。

#include<stdio.h>
#include<string.h>
int map[137][137],dp[137],n;
int dpp()
{
    int i,sum=0,flag=-1000000;
    for(i=0;i<n;i++)
    {
        sum+=dp[i];
        if(sum<0)sum=0;
        if(sum>flag)flag=sum;
    }
    return flag;
}
int main()
{
    int i,j,k,l,max=0,t;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=0; i<n; i++)
            for(j=0; j<n; j++)
                scanf("%d",&map[i][j]);
                int ans=-1;
        for(i=0; i<n; i++)//从第几行开始
        {
            for(j=0; j<n; j++)//行数
            {
                if(i+j<n)
                {
                    memset(dp,0,sizeof(dp));
                    for(k=i;k<=i+j;k++)//k和l构成一个列数为n的子矩阵
                    for(l=0;l<n;l++)
                    {
                        dp[l]+=map[k][l];
                    }
                    max=dpp();//从列数分别1到n的子矩阵中找出和的最大值
                    if(max>ans)ans=max;
                }

            }
        }
        printf("%d\n",ans);
    }

    return 0;
}

 

抱歉!评论已关闭.