现在的位置: 首页 > 综合 > 正文

pat:1021

2014年09月05日 ⁄ 综合 ⁄ 共 773字 ⁄ 字号 评论关闭

http://pat.zju.edu.cn/contests/pat-b-practise/1021

1021. 个位数统计 (15)

给定一个k位整数N = dk-1*10k-1 + ... + d1*101 + d0 (0<=di<=9, i=0,...,k-1,
dk-1>0),请编写程序统计每种不同的个位数字出现的次数。例如:给定N = 100311,则有2个0,3个1,和1个3。

输入格式:

每个输入包含1个测试用例,即一个不超过1000位的正整数N。

输出格式:

对N中每一种不同的个位数字,以D:M的格式在一行中输出该位数字D及其在N中出现的次数M。要求按D的升序输出。

输入样例:

100311

输出样例:

0:2
1:3
3:1

// PAT, 简单题集


#include <stdio.h>
#include <cctype>
#include <cmath>
#include <cstring>

#include <iostream>
#include <string>
#include <algorithm>
#include <vector>
#include <queue>
#include <stack>


#define SIZE 1010

using namespace std;

int main(){
#ifdef ONLINE_JUDGE
#else	
	freopen("E:\\in.txt", "r" , stdin);
#endif

	char buf[SIZE];
	while(scanf("%s", buf) != EOF){
		int hash[20]={0};
		int i=0;
		while(buf[i] != '\0'){
			hash[buf[i]-'0']++;
			i++;
		}//while

		for(i=0; i<=9; i++)
		{
			if(hash[i] != 0)
				printf("%d:%d\n", i, hash[i]);
		}
	}//while


	return 0;
}

抱歉!评论已关闭.