现在的位置: 首页 > 综合 > 正文

HDU2577:How to Type(DP)

2014年09月05日 ⁄ 综合 ⁄ 共 1532字 ⁄ 字号 评论关闭
Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type
the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
 


Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string
is at most 100.
 


Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
 


Sample Input
3 Pirates HDUacm HDUACM
 


Sample Output
8 8 8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8

 

题意:要求一个字符串输入,按键盘的最少次数。有Caps Lock和Shift两种转换大小写输入的方式

思路:用dpa与dpb数组分别记录Caps Lock的开关状态

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

char str[111];
int dpa[111],dpb[111];

int main()
{
    int t,i,len,flag;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",str+1);
        dpa[0] = 0;
        dpb[0] = 1;
        for(i = 1; str[i]; i++)
        {
            if(str[i]>='a' && str[i]<='z')
            {
                dpa[i] = min(dpa[i-1]+1,dpb[i-1]+2);//若灯亮,则直接按字母;若灯灭,则按字母再开灯
                dpb[i] = min(dpa[i-1]+2,dpb[i-1]+2);//若灯亮,则要先按字母再关灯;若灯灭,则按shift+字母
            }
            else if(str[i]>='A' && str[i]<='Z')
            {
                dpa[i] = min(dpa[i-1]+2,dpb[i-1]+2);
                dpb[i] = min(dpa[i-1]+2,dpb[i-1]+1);
            }
        }
        printf("%d\n",min(dpb[i-1]+1,dpa[i-1]));//最后要关灯,dpb要+1
    }

    return 0;
}

 

抱歉!评论已关闭.