现在的位置: 首页 > 综合 > 正文

ZOJ3706:Break Standard Weight(DP)

2014年09月05日 ⁄ 综合 ⁄ 共 2414字 ⁄ 字号 评论关闭

The balance was the first mass measuring instrument invented. In its traditional form, it consists of a pivoted horizontal lever of equal length arms, called the beam, with a weighing pan, also called scale,
suspended from each arm (which is the origin of the originally plural term "scales" for a weighing instrument). The unknown mass is placed in one pan, and standard masses are added to this or the other pan until the beam is as close to equilibrium as possible.
The standard weights used with balances are usually labeled in mass units, which are positive integers.

With some standard weights, we can measure several special masses object exactly, whose weight are also positive integers in mass units. For example, with two standard weights 1 and 5,
we can measure the object with mass 1, 4, 5 or 6 exactly.

In the beginning of this problem, there are 2 standard weights, which masses are x and y. You have to choose a standard weight to break it into 2 parts, whose weights are also
positive integers in mass units. We assume that there is no mass lost. For example, the origin standard weights are 4 and 9, if you break the second one into 4 and 5,
you could measure 7 special masses, which are 1, 3, 4, 5, 8, 9, 13. While if you break the first one into 1 and 3, you could measure 13 special
masses, which are 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13! Your task is to find out the maximum number of possible special masses.

Input

There are multiple test cases. The first line of input is an integer T < 500 indicating the number of test cases. Each test case contains 2 integers x and y.
2 ≤ x, y ≤ 100

Output

For each test case, output the maximum number of possible special masses.

Sample Input

2
4 9
10 10

Sample Output

13
9
 
题意:两个砝码,将其中一个拆分后,得到三个数字,问这三个数字通过加减能组合成多少个数字
思路:用DP数组来记录所有状态
 
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;

int hash[105][105][105],dp[10][205],x,y,MAX,n[4],sum;

int cmp(int x,int y)
{
    return x>y;
}


void solve()
{
    int i,j,k,l,w;
    memset(dp,0,sizeof(dp));
    dp[0][0] = 1;
    int ans = 0;
    sum = x+y;
    for(i = 1; i<=3; i++)
    {
        w = n[i];
        memcpy(dp[i],dp[i-1],sizeof(dp[0]));
        for(j = sum; j>0; j--)
        {
            if(j>=w)//可以放置,差j-w
            {
                if(dp[i-1][j-w])//补成j
                    dp[i][j] = 1;
                if(dp[i-1][j])//差j-w
                    dp[i][j-w] = 1;
            }
            else
            {
                if(dp[i-1][j])//差w-j
                    dp[i-1][w-j] = 1;
            }
        }
    }
    for(i = 1; i<=sum; i++)
    {
        if(dp[3][i])
            ans++;
    }
    if(ans>MAX)
        MAX = ans;
}

int main()
{
    int t,i;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&x,&y);
        memset(hash,0,sizeof(hash));
        MAX = 0;
        sum = x+y;
        n[0] = 10000000;
        for(i = 1; i<=x/2; i++)
        {
            n[1] = i;
            n[2] = x-i;
            n[3] = y;
            sort(n,n+4,cmp);
            if(!hash[n[1]][n[2]][n[3]])
            {
                hash[n[1]][n[2]][n[3]] = 1;
                solve();
            }
        }
        for(i = 1; i<=y/2; i++)
        {
            n[1] = i;
            n[2] = y-i;
            n[3] = x;
            sort(n,n+4,cmp);
            if(!hash[n[1]][n[2]][n[3]])
            {
                hash[n[1]][n[2]][n[3]] = 1;
                solve();
            }
        }
        printf("%d\n",MAX);
    }

    return 0;
}

抱歉!评论已关闭.