现在的位置: 首页 > 综合 > 正文

HDOJ 4848 Wow! Such Conquering!

2017年11月24日 ⁄ 综合 ⁄ 共 2513字 ⁄ 字号 评论关闭

dfs+减枝....

Wow! Such Conquering!

Time Limit: 15000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 651    Accepted Submission(s): 195


Problem Description
There are n Doge Planets in the Doge Space. The conqueror of Doge Space is Super Doge, who is going to inspect his Doge Army on all Doge Planets. The inspection starts from Doge Planet 1 where DOS (Doge Olympic Statue) was built. It takes Super Doge exactly
Txy time to travel from Doge Planet x to Doge Planet y.
With the ambition of conquering other spaces, he would like to visit all Doge Planets as soon as possible. More specifically, he would like to visit the Doge Planet x at the time no later than Deadlinex. He also wants the sum of all arrival time
of each Doge Planet to be as small as possible. You can assume it takes so little time to inspect his Doge Army that we can ignore it.
 


Input
There are multiple test cases. Please process till EOF.
Each test case contains several lines. The first line of each test case contains one integer: n, as mentioned above, the number of Doge Planets. Then follow n lines, each contains n integers, where the y-th integer in the x-th line is Txy . Then
follows a single line containing n - 1 integers: Deadline2 to Deadlinen.
All numbers are guaranteed to be non-negative integers smaller than or equal to one million. n is guaranteed to be no less than 3 and no more than 30.
 


Output
If some Deadlines can not be fulfilled, please output “-1” (which means the Super Doge will say “WOW! So Slow! Such delay! Much Anger! . . . ” , but you do not need to output it), else output the minimum sum of all arrival time to each Doge Planet.
 


Sample Input
4 0 3 8 6 4 0 7 4 7 5 0 2 6 9 3 0 30 8 30 4 0 2 3 3 2 0 3 3 2 3 0 3 2 3 3 0 2 3 3
 


Sample Output
36 -1
Hint
Explanation: In case #1: The Super Doge travels to Doge Planet 2 at the time of 8 and to Doge Planet 3 at the time of 12, then to Doge Planet 4 at the time of 16. The minimum sum of all arrival time is 36.
 


Source
 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>

using namespace std;

int n,ans;
int g[40][40],deadline[40];
bool vis[40];

void dfs(int u,int alltime,int time,int num)
{
    if(num==0)
    {
        ans=min(ans,alltime);
        return ;
    }
    for(int i=1;i<=n;i++)
    {
        if(vis[i]) continue;
        int T=time+g[u][i];
        bool flag=true;
        if(alltime+T*(num-1)>ans) continue;
        for(int j=1;j<=n;j++)
        {
            if(vis[j]) continue;
            if(deadline[j]<T)
            {
                flag=false;
                break;
            }
        }
        if(flag==false) continue;
        vis[i]=true;
        dfs(i,alltime+T,T,num-1);
        vis[i]=false;
    }
}

int main()
{
while(scanf("%d",&n)!=EOF)
{
    memset(g,63,sizeof(g));
    memset(vis,false,sizeof(vis));
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
            scanf("%d",&g[i][j]);
    for(int i=2;i<=n;i++)
        scanf("%d",deadline+i);
    for(int k=1;k<=n;k++)
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                g[i][j]=min(g[i][j],g[i][k]+g[k][j]);
    ans=0x3f3f3f3f;
    vis[1]=true;
    dfs(1,0,0,n-1);
    if(ans==0x3f3f3f3f) ans=-1;
    printf("%d\n",ans);
}
    return 0;
}

抱歉!评论已关闭.