现在的位置: 首页 > 综合 > 正文

POJ 1564 Sum It Up(DFS)

2018年01月12日 ⁄ 综合 ⁄ 共 2594字 ⁄ 字号 评论关闭
Sum It Up
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 5509   Accepted: 2778

Description

Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t = 4, n = 6, and the list is [4, 3, 2, 2, 1, 1], then there are four different sums that equal 4: 4, 3+1, 2+2, and 2+1+1.
(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

Input

The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x 1 , . . . , x n . If n = 0 it signals the end of the input; otherwise, t will be a
positive integer less than 1000, n will be an integer between 1 and 12 (inclusive), and x 1 , . . . , x n will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and
there may be repetitions.

Output

For each test case, first output a line containing `Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line `NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated
in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number
must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distinct; the same sum cannot appear twice.

Sample Input

4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0

Sample Output

Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25

题目大意:给你一个数t,以及n个数。若能用n当中的一些数组成t。便输出相应的组合。如果一组都没有的话,输出NONE。


分析:其实题目还是比较简单的,一看就是DFS的一个运用。不过以前一直是用DFS搞搞图,或者搞搞比较简单的深度搜索。而偏偏这道题需要对DFS的分层有很深的了解。

虽说之前写的丑陋了一些,但是还是搞出来,可是这道题其实最难的还是如何去重。我从网上看到了一个很牛的写法,涨姿势了!!!

(具体的解释写在代码里面吧)


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<map>
#include<queue>
#include<stack>
#include<vector>
#include<ctype.h>
#include<algorithm>
#include<string>
#define PI acos(-1.0)
#define maxn 1000
#define INF 1<<25
using namespace std;
int t,n,a[15]={0},b[15]={0};
bool flag=false;
void dfs(int sum, int x, int p)
{
    int i;
    if (sum==0)//如果可以组合为sum,输出
    {
        flag=true;
        printf("%d",b[i]);
        for (i=1; i<p; i++)
            printf("+%d",b[i]);
        printf("\n");
        return ;
    }
    for (i=x; i<n; i++)//x代表了是第几层
        if (i==x || a[i]!=a[i-1])//如果i=x,即使该层的首个元素,那么肯定可以选,其次是用a[i]!=a[i-1]这个判断删去在同一层中重复的元素
        {
            b[p]=a[i];
            dfs(sum-a[i],i+1,p+1);
        }
}
int main ()
{
    while(cin>>t>>n)
    {
        if (n==0) break;
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for (int i=0; i<n; i++) cin>>a[i];
        flag=false;
        printf("Sums of %d:\n",t);
        dfs(t,0,0);
        if (!flag) printf("NONE\n");
    }
    return 0;
}

【上篇】
【下篇】

抱歉!评论已关闭.