现在的位置: 首页 > 综合 > 正文

HDU 1086 You can Solve a Geometry Problem too(判断线段是否相交,非规范相交)

2013年09月08日 ⁄ 综合 ⁄ 共 1924字 ⁄ 字号 评论关闭

You can Solve a Geometry Problem too

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5486    Accepted Submission(s): 2619


Problem Description
Many geometry(几何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now
attending an exam, not a contest :)
Give you N (1<=N<=100) segments(线段), please output the number of all intersections(交点). You should count repeatedly if M (M>2) segments intersect at the same point.

Note:
You can assume that two segments would not intersect at more than one point. 

 


Input
Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending. 
A test case starting with 0 terminates the input and this test case is not to be processed.
 


Output
For each case, print the number of intersections, and one line one case.
 


Sample Input
2 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.00 3 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.000 0.00 0.00 1.00 0.00 0
 


Sample Output
1 3
 


Author
lcy
 
这个题目就是判断线段是否规范相交,其实没什么难度,找个模板套一下就OK 了,还有就是注意可能交点是端点
这个利用的是跨立实验
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
struct point
{
double x;
double y;
};
struct line
{
point a;
point b;
}node[1000];

double multi(point p0, point p1, point p2)//j计算差乘
{   return (p1.x-p0.x)*(p2.y-p0.y)-(p2.x-p0.x)*(p1.y-p0.y);}
bool is_cross(point s1,point e1,point s2,point e2)//判断线段是否相交(非规范相交)
{
   return max(s1.x,e1.x) >= min(s2.x,e2.x)&&
          max(s2.x,e2.x) >= min(s1.x,e1.x)&&
          max(s1.y,e1.y) >= min(s2.y,e2.y)&&
          max(s2.y,e2.y) >= min(s1.y,e1.y)&&
          multi(s1,e1,s2)*multi(s1,e1,e2) <= 0&&
          multi(s2,e2,s1)*multi(s2,e2,e1) <= 0;
}
int main()
{
int n;
int i,j,k;
int ans;
while(scanf("%d",&n),n)
{
ans=0;
for(i=0;i<n;i++)
{
scanf("%lf%lf%lf%lf",&node[i].a.x,&node[i].a.y,&node[i].b.x,&node[i].b.y);
for(j=0;j<i;j++)
if(is_cross(node[j].a,node[j].b,node[i].a,node[i].b))
ans++;
}
printf("%d\n",ans);
}
return 0;
}

抱歉!评论已关闭.