现在的位置: 首页 > 综合 > 正文

POJ 1961 Period(KMP 求循环)

2013年09月01日 ⁄ 综合 ⁄ 共 1671字 ⁄ 字号 评论关闭
Period
Time Limit: 3000MS   Memory Limit: 30000K
Total Submissions: 11026   Accepted: 5082

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is
one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing
order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

Source

这个题目在杭电上做过,这次再来一遍

做这个题目首先不止是对KMP知道,还要有一定程度的理解

我们要知道kmp是表示当前位置前面的next[i]个字母和从串开头的next[i]个字母组成的串相同

这个题目就是利用当前的位置

如果

i/(i-next[i])是一个整数,那么一定是个i/(i-next[i])长度的一个循环

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
using namespace std;
char name[1000010];
int next[1000010];
int get_next()
{
int i=0,j=-1;
next[0]=-1;
while(name[i])
{
if(j==-1 || name[i]==name[j])
{
i++,j++;
next[i]=j;
}
else
j=next[j];
}
return 0;
}
int main()
{
int n;
int i;
int t=0;
while(scanf("%d",&n),n)
{
t++;
scanf("%s",name);
get_next();
/*
for(i=0;i<=n;i++)
printf("%d ",next[i]);
printf("\n");
*/
printf("Test case #%d\n",t);
for(i=1;i<=n;i++)
if(next[i]!=0 && (i)%(i-next[i])==0)
printf("%d %d\n",i,(i)/(i-next[i]));
printf("\n");
}
return 0;
}

抱歉!评论已关闭.