现在的位置: 首页 > 综合 > 正文

hdu3584 Cube 树状数组

2013年10月03日 ⁄ 综合 ⁄ 共 1666字 ⁄ 字号 评论关闭

 

Cube

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 48    Accepted Submission(s): 32

Problem Description
Given an N*N*N cube A, whose elements are either 0 or 1. A[i, j, k] means the number in the i-th row , j-th column and k-th layer. Initially we have A[i, j, k] = 0 (1 <= i, j, k <= N). 
We define two operations, 1: “Not” operation that we change the A[i, j, k]=!A[i, j, k]. that means we change A[i, j, k] from 0->1,or 1->0. (x1<=i<=x2,y1<=j<=y2,z1<=k<=z2).
0: “Query” operation we want to get the value of A[i, j, k].
 

 

Input
Multi-cases.
First line contains N and M, M lines follow indicating the operation below.
Each operation contains an X, the type of operation. 1: “Not” operation and 0: “Query” operation.
If X is 1, following x1, y1, z1, x2, y2, z2.
If X is 0, following x, y, z.
 

 

Output
For each query output A[x, y, z] in one line. (1<=n<=100 sum of m <=10000)
 

 

Sample Input
2 5 1 1 1 1 1 1 1 0 1 1 1 1 1 1 1 2 2 2 0 1 1 1 0 2 2 2
 

 

Sample Output
1 0 1
 

 

Author
alpc32
 

 

Source
题目一开始TLE好多次,没办法看了解题报告说要用树状数组解决的,于是又去学了下树状数组;确实很优雅
#include<iostream>
using namespace std;
const int N=102;
int c[N][N][N];
int lowbit(int t)
{
return t&(-t);
}
void Trans(int div,int x,int y)
{
int t;
while(x>0)
{
t=y;
while(t>0)
{
c[div][x][t]=1-c[div][x][t];
t-=lowbit(t);
}
x -= lowbit(x);
}
}
int Plus(int div,int x,int y)
{
int t,sum=0;
while(x<N)
{
t=y;
while(t<N)
{
sum=(sum+c[div][x][t])&1;
t += lowbit(t);
}
x += lowbit(x);
}
return sum;
}
int main()
{
int n,m,i,j,x1,x2,y1,y2,z1,z2;
while(scanf("%d%d",&n,&m)!=EOF)
{
int flag;
int s,e;
memset(c,0,sizeof(c));
while(m --)
{
scanf("%d",&flag);
if(flag)
{
scanf("%d%d%d",&x1,&y1,&z1);
scanf("%d%d%d",&x2,&y2,&z2);
for(i=z1;i<=z2;i++)
{
Trans(i,x2,y2);
Trans(i,x2,y1-1);
Trans(i,x1-1,y2);
Trans(i,x1-1,y1-1);
}
}
else
{
scanf("%d%d%d",&x1,&y1,&z1);
printf("%d/n",Plus(z1,x1,y1));
}
}
}
return 0;
}
 

 

抱歉!评论已关闭.