现在的位置: 首页 > 综合 > 正文

UVA 10025 (13.08.06)

2013年10月05日 ⁄ 综合 ⁄ 共 970字 ⁄ 字号 评论关闭

 The ? 1 ? 2 ? ... ? n = k problem 


Theproblem

Given the following formula, one can set operators '+' or '-' instead of each '?', in order to obtain a given k
? 1 ? 2 ? ... ? n = k

For example: to obtain k = 12 , the expression to be used will be:
- 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12
with n = 7

TheInput

The first line is the number of test cases, followed by a blank line.

Each test case of the input contains integer k (0<=|k|<=1000000000).

Each test case will be separated by a single line.

The Output

For each test case, your program should print the minimal possible n (1<=n) to obtain k with the above formula.

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2

12

-3646397

Sample Output

7

2701

题意不累赘~

做法:

假设sum1 = a1 + a2 + a3 + ... + an + x >= k

而sum2 = a1 + a2 + a3 + ... + an - x = k

那么sum1 - sum2 = 2x

也就是说, 无论k的正负, 全把k当正数处理, 一直累加正数得到sum1 与 不按全当正数处理得到的sum2 相差的值是一个偶数(2x, 即负数的绝对值的两倍~)

故, 全部从1累加到n吧, 直到 (sum >= k && (sum - k) % 2 == 0)

AC代码:

#include<stdio.h>

int T;

int main() {
    scanf("%d", &T);
    while(T--) {
        int k;
        int sum = 0;
        scanf("%d", &k);
        if(k < 0)
            k = (-1 * k);
        for(int i = 1; ;i++) {
            sum += i;
            if(sum >= k && (sum-k) % 2 == 0) {
                printf("%d\n", i);
                break;
            }
        }
        if(T)
            printf("\n");
    }
    return 0;
}

抱歉!评论已关闭.