现在的位置: 首页 > 综合 > 正文

poj_3627Bookshelf

2013年10月22日 ⁄ 综合 ⁄ 共 1297字 ⁄ 字号 评论关闭
Bookshelf
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6316   Accepted: 3155

Description

Farmer John recently bought a bookshelf for cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

Each of the N cows (1 ≤ N ≤ 20,000) has some height of Hi (1 ≤ Hi ≤ 10,000) and a total height summed across all N cows of S. The bookshelf has a height of B (1 ≤ B ≤S <
2,000,000,007).

To reach the top of the bookshelf taller than the tallest cow, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height
of the bookshelf. Since more cows than necessary in the stack can be dangerous, your job is to find the set of cows that produces a stack of the smallest number of cows possible such that the stack can reach the bookshelf.

Input

* Line 1: Two space-separated integers: N and B
* Lines 2..N+1: Line i+1 contains a single integer: Hi

Output

* Line 1: A single integer representing the size of the smallest set of cows that can reach the bookshelf.

Sample Input

6 40
6
18
11
13
19
11

Sample Output

3

排序后,贪心。

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
int cow[20005];
#pragma warning(disable : 4996)
int main()
{
	freopen("in.txt", "r", stdin);
	int n, b, i;
	cin >> n >> b;
	for(int i = 1; i <= n; i++)
	{
		cin >> cow[i];
	}
	sort(cow + 1, cow + n + 1);
	int sum = 0;
	for(i = n; i >= 1; i--)
	{
		sum += cow[i];
		if(sum >= b)
		{
			break;
		}
	}
	cout << n - i + 1 << endl;
}

抱歉!评论已关闭.