现在的位置: 首页 > 综合 > 正文

1002 Fire Net

2013年04月30日 ⁄ 综合 ⁄ 共 2482字 ⁄ 字号 评论关闭

Fire Net


Time Limit: 2 Seconds     
Memory Limit:
65536 KB


Suppose that we have a square city with straight streets. A map of a city is a squareboard with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand,a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city aspossible so that no two can destroy each other. A configuration ofblockhouses islegal provided that no two blockhouses are on the samehorizontal row or vertical column
in a map unless there is at least one wallseparating them. In this problem we will consider small square cities (at most 4x4) that contain walls through whichbullets cannot run through.

The following image shows five pictures of the same board. Thefirst picture is the empty board, the second and third pictures show legalconfigurations, and the fourth and fifth pictures show illegal configurations.For this board, the maximum number of blockhouses
in a legal configurationis 5; the second picture shows one way to do it, but there are severalother ways.

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in thecity in a legal configuration.

The input file contains one or more map descriptions, followed bya line containing the number 0 that signals the end of the file. Eachmap description begins with a line containing a positive integernthat is the size of the city;n will be
at most 4. The next nlines each describe one row of the map, with a '.' indicating anopen space and an uppercase 'X' indicating a wall. There are nospaces in the input file.

For each test case, output one line containing themaximum number of blockhouses that can be placed in the cityin a legal configuration.

Sample input:

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample output:

5
1
5
2
4

#include<iostream>
using namespace std;
char map[5][5];
int n;
int mmax;
void init(){
int i,j;
for(i=0;i<n;i++) {
for(j=0;j<n;j++)
cin>>map[i][j];
}
}
int Putcan(int col,int row){
int i,j;
for(i=row-1;i>=0;i--) {
if(map[col][i]=='0')
return 0;
else if(map[col][i]=='X')
break;
}
for(j=col-1;j>=0;j--) {
if(map[j][row]=='0')
return 0;
else if(map[j][row]=='X') break;
}
return 1;
}
void Slove(int pos,int ccount){
int col,row;
if(pos==n*n) {
if(mmax<ccount)
mmax=ccount;
return;
}
col=pos/n;
row=pos%n;
if(map[col][row]=='.'&&Putcan(col,row)) {
map[col][row]='0';
Slove(pos+1,ccount+1);
map[col][row]='.';
}
Slove(pos+1,ccount);
}
int main(){
while(cin>>n&&n) {
mmax=0;
init();
Slove(0,0);
cout<<mmax<<endl;
}
return 0;
}

抱歉!评论已关闭.