现在的位置: 首页 > 综合 > 正文

武汉科技大学计算机学院菜鸟杯:find your present (2).(杭电2095)

2013年10月16日 ⁄ 综合 ⁄ 共 1163字 ⁄ 字号 评论关闭

find your present (2)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/1024 K (Java/Others)
Total Submission(s): 11199    Accepted Submission(s): 4093

Problem Description
In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and
your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card
number of 3, because 3 is the number that different from all the others.

Input
The input file will consist of several cases.
Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.

Output
For each case, output an integer in a line, which is the card number of your present.

Sample Input
5 1 1 3 2 2 3 1 2 1 0

Sample Output
3
2

 

 

代码如下:

/*抑或是一个很奇妙的运算符 a^a=0 这样出现偶数次的数抑或后就都没有了,只剩下唯一一个奇数次的了*/
#include <stdio.h>
int main()
{
    int a, n, b;
    while(scanf("%d", &n), n)
    {
        a = 0;
        while(n--)
        {
            scanf("%d", &b);
            a ^= b;
        }
        printf("%d\n", a);
    }
    return 0;
}

 

抱歉!评论已关闭.