现在的位置: 首页 > 综合 > 正文

POJ 1002 487-3279

2013年07月09日 ⁄ 综合 ⁄ 共 4264字 ⁄ 字号 评论关闭

一、题目信息

487-3279
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 198447   Accepted: 34554

Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of
the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza
Hut by calling their ``three tens'' number 3-10-10-10. 

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows: 

A, B, and C map to 2 
D, E, and F map to 3 
G, H, and I map to 4 
J, K, and L map to 5 
M, N, and O map to 6 
P, R, and S map to 7 
T, U, and V map to 8 
W, X, and Y map to 9 

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010. 

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.) 

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number. 

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number
alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters. 

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange
the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line: 

No duplicates. 

Sample Input

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output

310-1010 2
487-3279 4
888-4567 3

二、算法分析

        本题用不到什么算法,只是一个输入以及转换的过程。

三、参考代码

1、C++(已通过POJ)

#include <iostream>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
using namespace std;
char convert(char c){
         if(c <= 'C') return '2';
         else if(c <= 'F') return '3';
         else if(c <= 'I') return '4';
         else if(c <= 'L') return '5';
         else if(c <= 'O') return '6';
         else if(c <= 'S') return '7';
         else if(c <= 'V') return '8';
         else if(c <= 'Y') return '9';
}
int main()
{
    int N;
    bool flag = false;
    cin >> N;
    map<string,int> telp_count;
    while(N--){
        string s,res;
        cin >> s;
        int i = 0;
       for(string::iterator s_it = s.begin();s_it != s.end();++s_it){
             if(*s_it >= '0' && *s_it <= '9') res.push_back(*s_it);
             if(*s_it >= 'A' && *s_it <= 'Z') res.push_back(convert(*s_it));
        }
        res.insert(3,1,'-');
        ++telp_count[res];
    }
    map<string,int>::iterator map_it = telp_count.begin();
    for(;map_it != telp_count.end();++map_it)
        if(map_it->second >= 2){
            flag = true;
            cout << map_it->first << " " << map_it->second << endl;
        }
    if(!flag)
        cout << "No duplicates." << endl;
    return 0;
}

2、C(尚未通过POJ,显示WA,欢迎讨论)

C代码看似没有问题,在NOJ里也通过了(不过NYOJ里这题数据很水,即使不写No duplicates.也不会报错)
#include <stdio.h>
#include <string.h>
#include <ctype.h>
#include <stdlib.h>
//#include <windows.h>
char convert(char c)
{
    if(isdigit(c))
        return c;
    else if(c <= 'C') return '2';
    else if(c <= 'F') return '3';
    else if(c <= 'I') return '4';
    else if(c <= 'L') return '5';
    else if(c <= 'O') return '6';
    else if(c <= 'S') return '7';
    else if(c <= 'V') return '8';
    else if(c <= 'Y') return '9';
}
int  compar(const void *a, const void *b)
{
    long *aa = (long *)a,*bb = (long *)b;
    return (*aa > *bb) ? 1 : (*aa == *bb ? 0 : -1);
}
int main(void)
{
    long n,*res,counter = 0 ,duplicate = 0;
    int i = 0 , j = 0,k = 0;
    char s[16],c;
    scanf("%ld",&n);
    res = (long *)malloc(sizeof(long)*n);
    while(j < n)
    {
        scanf("%s",s);
        for(i = k = 0;s[i]!='\0';i++)
        {
            if(s[i] == '-')
                continue;
            else
                s[k++] = convert(s[i]);
        }
        s[k] = '\0';        
        res[j++] = atol(s);
    }
    qsort(res,n,sizeof(long),compar);
    counter = 1;
    for(i = 1; i < n; i++)
    {
        if(res[i-1] == res[i])
        {
            counter++;
            if(i == n-1 && counter > 1)
            {
                printf("%0.3ld-%0.4ld %ld\n",res[i-1]/10000,res[i-1]%10000,counter);
                duplicate++;
                break;
            }
        }
        else if(res[i-1] != res[i])
        {
            if(counter >= 2)
            {
                printf("%0.3ld-%0.4ld %ld\n",res[i-1]/10000,res[i-1]%10000,counter);
                duplicate++;
            }
            counter = 1;
        }
    }
    if(duplicate == 0)
        printf("No duplicates.\n");
    //system("pause");
    return 0;
}

抱歉!评论已关闭.