现在的位置: 首页 > 综合 > 正文

成环求连续m个最大序列

2013年10月29日 ⁄ 综合 ⁄ 共 1138字 ⁄ 字号 评论关闭

题意:如题...

主要还是数据太弱了...直接暴力过了...

There are N little kids sitting in a circle, each of them are carrying some java beans in their hand. Their teacher want to select
M kids who seated in M consecutive seats and collect java beans from them.

The teacher knows the number of java beans each kids has, now she wants to know the maximum number of java beans she can get from
M consecutively seated kids. Can you help her?

Input

There are multiple test cases. The first line of input is an integer T indicating the number of test cases.

For each test case, the first line contains two integers N (1 ≤ N ≤ 200) and
M (1 ≤ MN). Here N and M are defined in above description. The second line of each test case contains
N integers Ci (1 ≤
Ci ≤ 1000) indicating number of java beans the
ith kid have.

Output

For each test case, output the corresponding maximum java beans the teacher can collect.

Sample Input

2
5 2
7 3 1 3 9
6 6
13 28 12 10 20 75

Sample Output

16
158
#include <stdio.h>
#include <string.h>
int a[410]; 
int s[410];
int main()
{
	int n,m,i,t,T;
	scanf("%d",&T); 
	while (T--)
	{
		scanf("%d%d",&n,&m);
		t=1;
		int max=0;
		memset(s,0,sizeof(s));
		for (i=1;i<=n;i++)
			scanf("%d",&a[i]);
		for (i=n+1;i<=2*n;i++)
			a[i]=a[i-n];
		for (i=1;i<=m;i++)
			s[1]+=a[i];
		for (i=m+1;i<=2*n;i++)
			s[++t]=s[t-1]+a[i]-a[i-m];
		for (i=1;i<=t;i++)
			if (max<s[i])
			max=s[i];
		printf("%d\n",max);
	}
	return 0;
} 

 

【上篇】
【下篇】

抱歉!评论已关闭.