现在的位置: 首页 > 综合 > 正文

【USACO】PROB Friday the Thirteenth

2013年10月26日 ⁄ 综合 ⁄ 共 2186字 ⁄ 字号 评论关闭


Friday the Thirteenth

Is Friday the 13th really an unusual event?

That is, does the 13th of the month land on a Friday less often than on any other day of the week? To answer this question, write a program that will compute the frequency that the 13th of each month lands on Sunday, Monday, Tuesday, Wednesday, Thursday, Friday,
and Saturday over a given period of N years. The time period to test will be from January 1, 1900 to December 31, 1900+N-1 for a given number of years, N. N is non-negative and will not exceed 400.

There are few facts you need to know before you can solve this problem:

  • January 1, 1900 was on a Monday.
  • Thirty days has September, April, June, and November, all the rest have 31 except for February which has 28 except in leap years when it has 29.
  • Every year evenly divisible by 4 is a leap year (1992 = 4*498 so 1992 will be a leap year, but the year 1990 is not a leap year)
  • The rule above does not hold for century years. Century years divisible by 400 are leap years, all other are not. Thus, the century years 1700, 1800, 1900 and 2100 are not leap years, but 2000 is a leap year.

Do not use any built-in date functions in your computer language.

Don't just precompute the answers, either, please.

PROGRAM NAME: friday

INPUT FORMAT

One line with the integer N.

SAMPLE INPUT (file friday.in)

20

OUTPUT FORMAT

Seven space separated integers on one line. These integers represent the number of times the 13th falls on Saturday, Sunday,
Monday, Tuesday, ..., Friday.

SAMPLE OUTPUT (file friday.out)

36 33 34 33 35 35 34


import java.io.BufferedReader;
import java.io.FileReader;
import java.io.FileWriter;
import java.io.IOException;

public class friday {
	public static void main(String[] args) throws IOException{
		BufferedReader br = new BufferedReader(new FileReader("friday.in"));
		FileWriter out = new FileWriter("friday.out");
		int[] week = {0,0,0,0,0,0,0};//Sat,Sun,Mon,Tue,Wen,Thi,Fri
		int[] month = {31,31,29,31,30,31,30,31,31,30,31,30};//Dec,Jan,Feb,Mar,Apr,May,Jun,July,Aug,Spet,Oct,Nov
		int N = Integer.parseInt(br.readLine());
		int start = 4;//1990 Jan the 13th is a Mon-2,so 1989 Dec the 13th is a Fri-6;  
		for(int i =0;i<N;i++){
			//wheather this year is leap year
			if((i+1900)%400==0||(i+1900)%100!=0&&(i+1900)%4==0){
				month[2]=29;
			}else{
				month[2]=28;
			}
			for(int j =0;j<12;j++){
				int tmp = (start+month[j])%7;
				week[tmp]++;
				start = tmp;
			}
		}
		for(int i=0;i<6;i++){
			out.write(week[i]+" ");
		}
		out.write(week[6]+"\n");
		out.flush();
		out.close();
		br.close();
	}
}

虽然可以通过,但是有点费解,就是要求的输出顺序为Sat、Sun、Mon、Tue、Wen、Thi、Fri,但是实际答案是周一-周日的顺序输出的,不知道是哪里的问题。。。

抱歉!评论已关闭.