现在的位置: 首页 > 综合 > 正文

POJ 2299 归并排序

2013年10月30日 ⁄ 综合 ⁄ 共 1678字 ⁄ 字号 评论关闭

         题意很简单,就是用归并排序求逆序数。本想直接水过,没想到还调试了那么长时间,,最郁闷的是还tle了几次。。。。。。。题目:

Ultra-QuickSort
Time Limit: 7000MS   Memory Limit: 65536K
Total Submissions: 24782   Accepted: 8862

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is
sorted in ascending order. For the input sequence 
9 1 0 5 4 ,


Ultra-QuickSort produces the output 
0 1 4 5 9 .


Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence
element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

ac代码:

#include <iostream>
#include <cstdio>
#include <string.h>
using namespace std;
#define M 500010
int a[M];
int b[M];
long long count;
void mergesort(int begin,int mid,int end){
  int num=begin;
  int i=begin,j=mid+1;
  while((i<=mid)&&(j<=end)){
    if(a[i]<=a[j])
		b[num++]=a[i++];
	else{
	  b[num++]=a[j++];
	  count+=(mid-i+1);
	}
  }
  if(i>mid){
    for(int k=j;k<=end;++k)
		b[num++]=a[k];
  }
  else{
	  for(int k=i;k<=mid;++k){
	    b[num++]=a[k];
	  }
  }
  for(int k=begin;k<num;++k){
    a[k]=b[k];
  }
}
void merge(int begin,int end){
  int mid;
  if(begin<end){
    mid=(begin+end)/2;
	merge(begin,mid);
	merge(mid+1,end);
	mergesort(begin,mid,end);
  }
}
int main(){
  int n;
  while(scanf("%d",&n),n){
    count=0;
	for(int i=1;i<=n;++i)
		scanf("%d",&a[i]);
	merge(1,n);
	printf("%lld\n",count);
  }
  return 0;
}

抱歉!评论已关闭.