现在的位置: 首页 > 综合 > 正文

杭电2841 容斥定理求1到n之间和x互质的数的总数

2013年10月20日 ⁄ 综合 ⁄ 共 1421字 ⁄ 字号 评论关闭

           第一次写容斥定理,完全不懂啊,,,弱爆了。。。。。话说这道题最后就是判断横坐标和纵坐标两个值是否互质,如果互质则可以看到,否则看不到。题目:

Visible Trees

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 593    Accepted Submission(s): 225


Problem Description
There are many trees forming a m * n grid, the grid starts from (1,1). Farmer Sherlock is standing at (0,0) point. He wonders how many trees he can see.

If two trees and Sherlock are in one line, Farmer Sherlock can only see the tree nearest to him.

 


Input
The first line contains one integer t, represents the number of test cases. Then there are multiple test cases. For each test case there is one line containing two integers m and n(1 ≤ m, n ≤ 100000)
 


Output
For each test case output one line represents the number of trees Farmer Sherlock can see.
 


Sample Input
2 1 1 2 3
 


Sample Output
1 5
 

ac代码:

#include <iostream>
#include <cstdio>
#include <vector>
using namespace std;
long long wid,len;
long long prime(long long x){
	vector<long long> ss;
	//先将x分解质因数
	for(long long i=2;i*i<=x;++i){
		if(x%i==0){
			ss.push_back(i);
			while(x%i==0)
				x/=i;
		}
	}
	if(x>1)  ss.push_back(x);
	//分解完毕
	long long count=0;
	//转化成二进制判断二进制中有多少个1
	for(long long i=1;i<(1<<ss.size());++i){
	   long long ones=0,mult=1;
	   for(long long j=0;j<ss.size();++j){
		   if(i&(1<<j)){//按位与运算,判断1的个数
		     ones++;
			 mult*=ss[j];
		   }
	   }
	   if(ones%2)  count+=(wid/mult);//(wid/mult)为其中有多少个数是mult的倍数,即不互质
	   else   count-=(wid/mult);
	}
	return wid-count;
}
int main(){
  int numcase;
  scanf("%d",&numcase);
  while(numcase--){
    long long sum=0;
	scanf("%lld%lld",&len,&wid);
	for(long long i=2;i<=len;++i){
	  sum+=(prime(i));
	}
	printf("%lld\n",sum+wid);
  }
  return 0;
}

抱歉!评论已关闭.