现在的位置: 首页 > 综合 > 正文

动态规划 杭电1069

2013年10月12日 ⁄ 综合 ⁄ 共 3502字 ⁄ 字号 评论关闭

     这道题真是一个纠结,,从上午8点开始一直写到现在,刚ac,,伤不起啊。早上想了好久,才想明白一个木块最多可以放三个,然后就是纠结怎么排序的问题了,,一直想了两个小时,算是想明白了。悲催的是,在NYOJ上ac了,在HDU上却怎么也ac不了,,又仔细想了想,每一个木块都应该分6种情况考虑,刚开始我只考虑了3种,,悲剧,,一天,,,终于A了一道题,没有光头。。。。。。。。。。题目:

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3095    Accepted Submission(s): 1615


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana
by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions
of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly
smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

 


Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 


Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 


Sample Input
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 


Sample Output
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342
 

ac代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <string.h>
using namespace std;
struct rectangular{
  int length;
  int width;
  int height;
  int area;
}aa[205];
bool cmp1(int a,int b){
  return a>b;
}
bool cmp2(rectangular a,rectangular b){
	return a.area>b.area;
}
int main(){
 //freopen("4.txt","r",stdin);
  int n;
  int count=1;
  while(scanf("%d",&n)&&n){
	int num[3],dp[205];
	for(int i=1;i<=6*n;i+=6){
	  for(int j=0;j<3;++j)
		  scanf("%d",&num[j]);
	  sort(num,num+3,cmp1);
	  aa[i].length=num[0];aa[i].width=num[1];aa[i].height=num[2];aa[i].area=aa[i].length*aa[i].width;
	  aa[i+1].length=num[1];aa[i+1].width=num[2];aa[i+1].height=num[0];aa[i+1].area=aa[i+1].length*aa[i+1].width;
	  aa[i+2].length=num[2];aa[i+2].width=num[0];aa[i+2].height=num[1];aa[i+2].area=aa[i+2].length*aa[i+2].width;
	  aa[i+3].length=num[1];aa[i+3].width=num[0];aa[i+3].height=num[2];aa[i+3].area=aa[i+3].length*aa[i+3].width;
	  aa[i+4].length=num[2];aa[i+4].width=num[1];aa[i+4].height=num[0];aa[i+4].area=aa[i+4].length*aa[i+4].width;
	  aa[i+5].length=num[0];aa[i+5].width=num[2];aa[i+5].height=num[1];aa[i+5].area=aa[i+5].length*aa[i+5].width;
	}
	sort(aa+1,aa+6*n,cmp2);
	for(int i=1;i<=6*n;++i)
		dp[i]=aa[i].height;
	for(int i=2;i<=6*n;++i){
		int xmax=0;
		for(int j=1;j<i;++j){
			if((aa[j].length>aa[i].length&&aa[j].width>aa[i].width)||(aa[j].length>aa[i].width&&aa[j].width>aa[i].length))
			if(dp[j]>xmax)
				xmax=dp[j];
		}
		dp[i]=xmax+aa[i].height;
	}
	int ymax=0;
	for(int i=1;i<=6*n;++i)
		if(dp[i]>ymax)
			ymax=dp[i];
	printf("Case %d: maximum height = %d\n",count++,ymax);
  }
  return 0;
}

抱歉!评论已关闭.