现在的位置: 首页 > 综合 > 正文

poj 3624 Charm Bracelet(01背包入门题)

2013年10月20日 ⁄ 综合 ⁄ 共 1289字 ⁄ 字号 评论关闭

Charm Bracelet
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10399   Accepted: 4667

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1
≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source

分析:这题算是01背包的入门题了,只是还要用到滚动数组,f[i]表示用掉i的重量,取得的最大值,
也就是f[i]=max(f[j]+d[k]) {j+w[k]=i}
代码:
#include<cstdio>
#include<iostream>
using namespace std;
const int mm=13333;
int f[mm],w[mm],d[mm];
int i,j,k,n,m;
int main()
{
    while(scanf("%d%d",&n,&m)!=-1)
    {
        for(i=0;i<n;++i)scanf("%d%d",&w[i],&d[i]);
        for(i=0;i<m;++i)f[i]=0;
        for(i=0;i<n;++i)
            for(j=m;j>=w[i];--j)f[j]=max(f[j],f[j-w[i]]+d[i]);
        printf("%d\n",f[m]);
    }
    return 0;
}

抱歉!评论已关闭.