现在的位置: 首页 > 综合 > 正文

poj 1434 Fill the Cisterns!(扫描线)

2013年10月16日 ⁄ 综合 ⁄ 共 2556字 ⁄ 字号 评论关闭
Fill the Cisterns!
Time Limit: 5000MS   Memory Limit: 10000K
Total Submissions: 2513   Accepted: 900

Description

During the next century certain regions on earth will experience severe water shortages. The old town of Uqbar has already started to prepare itself for the worst. Recently they created a network of pipes connecting the cisterns that distribute water in each
neighbourhood, making it easier to fill them at once from a single source of water. But in case of water shortage the cisterns above a certain level will be empty since the water will to the cisterns below. 



You have been asked to write a program to compute the level to which cisterns will be lled with a certain volume of water, given the dimensions and position of each cistern. To simplify we will neglect the volume of water in the pipes. 

Task 

Write a program which for each data set: 

reads the description of cisterns and the volume of water, 

computes the level to which the cisterns will be filled with the given amount of water, 

writes the result. 

Input

The first line of the input contains the number of data sets k, 1 <= k <= 30. The data sets follow. 

The first line of each data set contains one integer n, the number of cisterns, 1 <= n <= 50 000. Each of the following n lines consists of 4 nonnegative integers, separated by single spaces: b, h, w, d - the base level of the cistern, its height, width and
depth in meters, respectively. The integers satisfy 0 <= b <= 10^6 and 1 <= h * w * d <= 40 000. The last line of the data set contains an integer V - the volume of water in cubic meters to be injected into the network. Integer V satisfies 1 <= V <= 2 * 10^9. 

Output

The output should consist of exactly d lines, one line for each data set. 

Line i, 1 <= i <= d, should contain the level that the water will reach, in meters, rounded up to two fractional digits, or the word 'OVERFLOW', if the volume of water exceeds the total capacity of the cisterns. 

Sample Input

3
2
0 1 1 1
2 1 1 1
1
4
11 7 5 1
15 6 2 2
5 8 5 1
19 4 8 1
132
4
11 7 5 1
15 6 2 2
5 8 5 1
19 4 8 1
78

Sample Output

1.00
OVERFLOW
17.00

Source

题目:http://poj.org/problem?id=1434

题意:给你n个相连的长方体容器,每个容器的高度不一,现在在容器里装体积为V的水,问是否能装下,能装下的话,水的最大高度是多少

分析:水往地处流,所有我们当然是从最底层开始装水,将所有高度离散化,这样对于许多长方体块,算出单位高度的装水量,也就是高度对应的面积,从下往上统计就行了

还有另一种做法就是二分高度,判断是否能装下,这里就不写了

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
const int mm=111111;
struct data
{
    int h,x;
}g[mm];
int s[mm];
int i,n,m,b,h,w,d,t;
double sum,ans,v;
bool cmp(data a,data b)
{
    return a.h<b.h;
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(sum=m=0,i=1;i<=n;++i)
        {
            scanf("%d%d%d%d",&b,&h,&w,&d);
            s[i]=w*d;
            g[m].h=b,g[m++].x=i;
            g[m].h=b+h,g[m++].x=-i;
            sum+=1.0*h*w*d;
        }
        scanf("%lf",&v);
        if(v>sum)puts("OVERFLOW");
        else
        {
            sort(g,g+m,cmp);
            ans=g[0].h;
            for(sum=i=0;v>0&&i<m;++i)
            {
                if(i>0&&g[i].h>g[i-1].h)
                {
                    v-=sum*(g[i].h-g[i-1].h);
                    ans+=(g[i].h-g[i-1].h);
                    if(v<0)ans+=v/sum;
                }
                if(g[i].x<0)sum-=s[-g[i].x];
                else sum+=s[g[i].x];
            }
            printf("%.2lf\n",ans);
        }
    }
    return 0;
}

抱歉!评论已关闭.