现在的位置: 首页 > 综合 > 正文

poj 2117(统计连通块的个数)

2013年10月27日 ⁄ 综合 ⁄ 共 3255字 ⁄ 字号 评论关闭

Electricity
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 1600   Accepted: 491

Description

Blackouts and Dark Nights (also known as ACM++) is a company that provides electricity. The company owns several power plants, each of them supplying a small area that surrounds it. This organization brings a lot of problems - it often happens that there is
not enough power in one area, while there is a large surplus in the rest of the country. 

ACM++ has therefore decided to connect the networks of some of the plants together. At least in the first stage, there is no need to connect all plants to a single network, but on the other hand it may pay up to create redundant connections on critical places
- i.e. the network may contain cycles. Various plans for the connections were proposed, and the complicated phase of evaluation of them has begun. 

One of the criteria that has to be taken into account is the reliability of the created network. To evaluate it, we assume that the worst event that can happen is a malfunction in one of the joining points at the power plants, which might cause the network
to split into several parts. While each of these parts could still work, each of them would have to cope with the problems, so it is essential to minimize the number of parts into which the network will split due to removal of one of the joining points. 

Your task is to write a software that would help evaluating this risk. Your program is given a description of the network, and it should determine the maximum number of non-connected parts from that the network may consist after removal of one of the joining
points (not counting the removed joining point itself). 

Input

The input consists of several instances. 

The first line of each instance contains two integers 1 <= P <= 10 000 and C >= 0 separated by a single space. P is the number of power plants. The power plants have assigned integers between 0 and P - 1. C is the number of connections. The following C lines
of the instance describe the connections. Each of the lines contains two integers 0 <= p1, p2 < P separated by a single space, meaning that plants with numbers p1 and p2 are connected. Each connection is described exactly once and there is at most one connection
between every two plants. 

The instances follow each other immediately, without any separator. The input is terminated by a line containing two zeros. 

Output

The output consists of several lines. The i-th line of the output corresponds to the i-th input instance. Each line of the output consists of a single integer C. C is the maximum number of the connected parts of the network that can be obtained by removing
one of the joining points at power plants in the instance.

Sample Input

3 3
0 1
0 2
2 1
4 2
0 1
2 3
3 1
1 0
0 0

Sample Output

1
2
2

Source

分析:题目要求去掉一个点,使得剩下最多不连通的块,我们可以先计算出原来有几个不连通的快,然后选一个连通快,去掉其割点,看一下去掉哪个割点后分出来的块最多,加上原来的块就是答案了,当没有边的时候应该是答案n-1,不过数据貌似没有。。。
代码:
#include<cstdio>
#define min(a,b) (a<b?a:b)
using namespace std;
const int mm=2222222;
const int mn=11111;
int t[mm],p[mm];
int h[mn],num[mn],dfn[mn],low[mn];
int i,j,k,rt,n,m,top,idn,cnt,sum,ans;
void dfs(int u,int fa)
{
    int i,v,cnt=0;
    dfn[u]=low[u]=++idn;
    for(i=h[u];i>=0;i=p[i])
        if(!dfn[v=t[i]])
        {
            dfs(v,u);
            ++cnt;
            low[u]=min(low[u],low[v]);
            if((u==rt&&cnt>1)||(u!=rt&&dfn[u]<=low[v]))++num[u];
        }
        else if(v!=fa)low[u]=min(low[u],dfn[v]);
}
void tarjan()
{
    for(top=idn=cnt=rt=0;rt<n;++rt)dfn[rt]=num[rt]=0;
    for(sum=ans=rt=0;rt<n;++rt)
    {
        if(!dfn[rt])dfs(rt,0),++sum;
        if(num[rt]>ans)ans=num[rt];
    }
    ans+=sum;
}
int main()
{
    while(scanf("%d%d",&n,&m),n+m)
    {
        if(m==0)
        {
            printf("%d\n",n-1);
            continue;
        }
        for(k=i=0;i<n;++i)h[i]=-1;
        while(m--)
        {
            scanf("%d%d",&i,&j);
            t[k]=j,p[k]=h[i],h[i]=k++;
            t[k]=i,p[k]=h[j],h[j]=k++;
        }
        tarjan();
        printf("%d\n",ans);
    }
    return 0;
}

抱歉!评论已关闭.