现在的位置: 首页 > 综合 > 正文

zoj 2107 Quoit Design(最近点对)

2013年10月02日 ⁄ 综合 ⁄ 共 2228字 ⁄ 字号 评论关闭

Quoit Design


Time Limit: 5 Seconds      Memory Limit: 32768 KB


Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a
configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered
to be 0.

Input

The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated
by N = 0.

Output

For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places.

Sample Input

2
0 0
1 1
2
1 1
1 1
3
-1.5 0
0 0
0 1.5
0

Sample Output

0.71
0.00
0.75


Author: CHEN, Yue
Source: Zhejiang Provincial Programming Contest 2004

题目:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=2107

题意:给你n个点,求最近的两个点的距离的一半。。。

分析:最近点对,貌似是第一次听说= =,可以用分治来做,先按x轴排序,然后每次将平面分成两半,分别求解 ,对于一次合并,先找出离划分线距离小于当前最小值的点,然后将这些点按y轴排序,其实x轴也一样,在暴力求这些点的最近点,每次y坐标的差值大于答案,直接break,我写的这个相当的暴力,不过还是A了,900++ms

有空再来优化下

代码:

#include<cmath>
#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
const int mm=111111;
typedef double diy;
struct point
{
    diy x,y;
    point(){}
    point(diy _x,diy _y):x(_x),y(_y){}
}g[mm];
int q[mm];
int n;
bool cmp(point p,point q)
{
    return p.x<q.x;
}
bool cmpy(int a,int b)
{
    return g[a].y<g[b].y;
}
diy Dis(point P,point Q)
{
    return sqrt((P.x-Q.x)*(P.x-Q.x)+(P.y-Q.y)*(P.y-Q.y));
}
diy NearPoint(int l,int r)
{
    if(l>=r)return 1e30;
    int i,j,n=0,m=(l+r)>>1;
    diy a=min(NearPoint(l,m),NearPoint(m+1,r));
    for(i=m;i>=l;--i)
        if(g[m].x-g[i].x<a)q[n++]=i;
        else break;
    for(i=m+1;i<=r;++i)
        if(g[i].x-g[m].x<a)q[n++]=i;
        else break;
    sort(q,q+n,cmpy);
    for(i=0;i<n;++i)
        for(j=i+1;j<n;++j)
            if(g[q[j]].y-g[q[i]].y<a)a=min(a,Dis(g[q[i]],g[q[j]]));
            else break;
    return a;
}
int main()
{
    while(scanf("%d",&n),n)
    {
        for(int i=0;i<n;++i)
            scanf("%lf%lf",&g[i].x,&g[i].y);
        sort(g,g+n,cmp);
        printf("%.2lf\n",NearPoint(0,n-1)/2);
    }
    return 0;
}

抱歉!评论已关闭.