现在的位置: 首页 > 综合 > 正文

HDU 2923 Einbahnstrasse (最短路,3级)

2013年10月02日 ⁄ 综合 ⁄ 共 4271字 ⁄ 字号 评论关闭
F - Einbahnstrasse

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d
& %I64u

Appoint description: 

Description

Einbahnstra  e (German for a one-way street) is a street on which vehicles should only move in one direction. One reason for having one-way streets is to facilitate
a smoother flow of traffic through crowded areas. This is useful in city centers, especially old cities like Cairo and Damascus. Careful planning guarantees that you can get to any location starting from any point. Nevertheless, drivers must carefully plan
their route in order to avoid prolonging their trip due to one-way streets. Experienced drivers know that there are multiple paths to travel between any two locations. Not only that, there might be multiple roads between the same two locations. Knowing the
shortest way between any two locations is a must! This is even more important when driving vehicles that are hard to maneuver (garbage trucks, towing trucks, etc.)

You just started a new job at a car-towing company. The company has a number of towing trucks parked at the company's garage. A tow-truck lifts the front or back wheels of a broken car in order to pull it straight back to the company's garage. You receive calls
from various parts of the city about broken cars that need to be towed. The cars have to be towed in the same order as you receive the calls. Your job is to advise the tow-truck drivers regarding the shortest way in order to collect all broken cars back in
to the company's garage. At the end of the day, you have to report to the management the total distance traveled by the trucks.

 

Input

Your program will be tested on one or more test cases. The first line of each test case specifies three numbers (N , C , and R ) separated by one or more spaces. The city has N locations with distinct names, including the company's
garage. C is the number of broken cars. R is the number of roads in the city. Note that 0 < N < 100 , 0<=C < 1000 , and R < 10000 . The second line is made of C + 1 words, the first being the location of the company's garage, and the rest being the locations
of the broken cars. A location is a word made of 10 letters or less. Letter case is significant. After the second line, there will be exactly R lines, each describing a road. A road is described using one of these three formats:

A -v -> B
A <-v - B
A <-v -> B

A and B are names of two different locations, while v is a positive integer (not exceeding 1000) denoting the length of the road. The first format specifies a one-way street from location A to B , the second specifies a one-way street from B to A , while the
last specifies a two-way street between them. A , ``the arrow", and B are separated by one or more spaces. The end of the test cases is specified with a line having three zeros (for N , C , and R .)

The test case in the example below is the same as the one in the figure. 

 

Output

For each test case, print the total distance traveled using the following format:

k . V

Where k is test case number (starting at 1,) is a space, and V is the result.

 

Sample Input

4 2 5 NewTroy Midvale Metrodale NewTroy <-20-> Midvale Midvale --50-> Bakerline NewTroy <-5-- Bakerline Metrodale <-30-> NewTroy Metrodale --5-> Bakerline 0 0 0
 

Sample Output

1. 80
 

思路:比较水的全源最短路,结果就是每次拖车+一次正反最短路就可以了。

坑:有重边,同一地点有多辆broken car

#include<cstdio>
#include<cstring>
#include<string>
#include<iostream>
#include<queue>
#include<map>
#define FOR(i,a,b) for(int i=a;i<=b;++i)
#define clr(f,z) memset(f,z,sizeof(f))
#define ll(x) (1<<x)
using namespace std;
const int msize=1009;
const int oo=0x3f3f3f3f;
map<string,int>mp;
class Edge
{
  public:int v,w,next;
};
class Short_Path
{
public:
  int dis[msize][msize];
  bool vis[msize];
  int n,m,edge,head[msize];
  Edge e[msize*msize];
  int car[msize];
  void clear()
  { clr(car,0);
    FOR(i,0,n)FOR(j,0,n)dis[i][j]=oo;
    edge=0;clr(head,-1);
  }
  void add(int u,int v,int w)
  {
    e[edge].v=v;e[edge].w=w;e[edge].next=head[u];head[u]=edge++;
  }
  void SPFA()
  {
    int u,v;
    clr(vis,0);
    FOR(t,0,n)
    {
      dis[t][t]=0;
      queue<int>Q;
      Q.push(t);
      while(!Q.empty())
      {
        u=Q.front();Q.pop();vis[u]=0;
        for(int i=head[u];~i;i=e[i].next)
        {
          v=e[i].v;
          if(dis[t][v]>dis[t][u]+e[i].w)
          {
            dis[t][v]=dis[t][u]+e[i].w;
            if(!vis[v])
            {
              Q.push(v);vis[v]=1;
            }
          }
        }
      }
    }
  }
  int get(int&x)
  {
    char z;x=0;
    int w;
    int num=0;
    while(1)
    {
      if(num)scanf("-%d-",&w);
      z=getchar();
      if(z=='<')x|=2,++num;
      if(z=='>')x|=1,++num;
      if(z=='-')++num;
      if(num==2)return w;
    }
  }
  void getans()
  { int ans=0;
    FOR(i,1,m)
    {
      ans+=car[i]*(dis[0][i]+dis[i][0]);
    }
    printf("%d\n",ans);
  }
}sp;
int main()
{ int a,b,c,p,pos;
  string ss;int cas=0;
  while(~scanf("%d%d%d",&sp.n,&sp.m,&p))
  { if(sp.n==0&&sp.m==0&&p==0)break;
    sp.clear();mp.clear();
    pos=0;
    FOR(i,0,sp.m)
    {
      cin>>ss;
      if(mp[ss]==0)
      mp[ss]=++pos;
      ++sp.car[ mp[ss]-1 ];
    }
    int t;
    FOR(i,1,p)
    {
      cin>>ss;
      if(mp[ss]==0)mp[ss]=++pos;
      a=mp[ss]-1;
      c=sp.get(t);
      cin>>ss;
      if(mp[ss]==0)mp[ss]=++pos;
      b=mp[ss]-1;
      if(t&1)sp.add(a,b,c);
      if(t&2)sp.add(b,a,c);
    }
    sp.SPFA();
    printf("%d. ",++cas);
    sp.getans();
  }
}

抱歉!评论已关闭.