现在的位置: 首页 > 综合 > 正文

hdu4750

2013年03月31日 ⁄ 综合 ⁄ 共 3456字 ⁄ 字号 评论关闭

Count The Pairs

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 238    Accepted Submission(s): 125

Problem Description


  With the 60th anniversary celebration of Nanjing University of Science and Technology coming soon, the university sets n tourist spots to welcome guests. Of course, Redwood forests in our university and its Orychophragmus violaceus must be recommended as
top ten tourist spots, probably the best of all. Some undirected roads are made to connect pairs of tourist spots. For example, from Redwood forests (suppose it’s a) to fountain plaza (suppose it’s b), there may exist an undirected road with its length c.
By the way, there is m roads totally here. Accidently, these roads’ length is an integer, and all of them are different. Some of these spots can reach directly or indirectly to some other spots. For guests, they are travelling from tourist spot s to tourist
spot t, they can achieve some value f. According to the statistics calculated and recorded by us in last years, We found a strange way to calculate the value f:
  From s to t, there may exist lots of different paths, guests will try every one of them. One particular path is consisted of some undirected roads. When they are travelling in this path, they will try to remember the value of longest road in this path. In
the end, guests will remember too many longest roads’ value, so he cannot catch them all. But, one thing which guests will keep it in mind is that the minimal number of all these longest values. And value f is exactly the same with the minimal number.
  Tom200 will recommend pairs (s, t) (start spot, end spot points pair) to guests. P guests will come to visit our university, and every one of them has a requirement for value f, satisfying f>=t. Tom200 needs your help. For each requirement, how many pairs
(s, t) you can offer?
 

 

Input
  Multiple cases, end with EOF.
  First line:n m
  n tourist spots ( 1<n<=10000), spots’ index starts from 0.
  m undirected roads ( 1<m<=500000).

  Next m lines, 3 integers, a b c
  From tourist spot a to tourist spot b, its length is c. 0<a, b<n, c(0<c<1000000000), all c are different.

  Next one line, 1 integer, p (0<p<=100000)
  It means p guests coming.

  Next p line, each line one integer, t(0<=t)
  The value t you need to consider to satisfy f>=t.

 

 

Output
  For each guest's requirement value t, output the number of pairs satisfying f>=t.
  Notice, (1,2), (2,1) are different pairs.
 

 

Sample Input
2 1 0 1 2 3 1 2 3 3 3 0 1 2 0 2 4 1 2 5 5 0 2 3 4 5
 

 

Sample Output
2 2 0 6 6 4 4 0
 

 

Source
 

 

Recommend
liuyiding

       本题规定两点之间的价值为所有路径中最长两点距离的最小值。给定所有的路径,即询问次数,然后每次询问给定一个临界价值f,问f<=t(t为两点价值的),求这样的两点组合数。

       如果把本题看做图论题,就不太好处理时间复杂度了。可以想想其他的方法。此题容易让人联想到并查集。先将所有的边按从小到大的顺序排序。然后依次插入。若当前边对应的两点属于某个集合,则其对应的价值小于当前边的权值。若不属于同一个集合,则由于排序的关系,其对应的价值就是当前边的权值,同时分属这两个集合的所有点的价值也为当前边的权值。集体看代码。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int MAXN=500000+100;
struct edg
{
	int s,t,dis;
}Edg[MAXN];
int Par[10000+100];
int Sum[10000+100];
__int64 ans[MAXN];
int index[MAXN];
int n,m,q,tot;

bool cmp(edg a,edg b)
{
	return a.dis<b.dis;
}

int Get_par(int child)
{
	if(child==Par[child])
		return child;
	return Par[child]=Get_par(Par[child]);
}

void init()
{
	int i;
	for(i=0;i<n;i++)
	{
		Par[i]=i;
		Sum[i]=1;
	}
}

void Solve()
{
	int i,fs,ft;
	tot=0;
	for(i=0;i<m;i++)
	{
		fs=Get_par(Edg[i].s);
		ft=Get_par(Edg[i].t);
		if(fs==ft)continue;
		Par[fs]=ft;
		
		index[tot]=Edg[i].dis;
		ans[tot++]=(__int64)Sum[ft]*Sum[fs];
		Sum[ft]=Sum[ft]+Sum[fs];
	}

	for(i=1;i<tot;i++)
	{
		ans[i]+=ans[i-1];
	}
}

int main()
{
	int i;
	__int64 f;
	while(~scanf("%d%d",&n,&m))
	{
		for(i=0;i<m;i++)
		{
			scanf("%d%d%d",&Edg[i].s,&Edg[i].t,&Edg[i].dis);
		}
		sort(Edg,Edg+m,cmp);
		init();
		Solve();

		scanf("%d",&q);
		while(q--)
		{
			scanf("%I64d",&f);
			int id=lower_bound(index,index+tot,f)-index;
			if(id==0)printf("%I64d\n",ans[tot-1]*2);
			else printf("%I64d\n",(ans[tot-1]-ans[id-1])*2);
		}
	}
	return 0;
}

 

抱歉!评论已关闭.