现在的位置: 首页 > 综合 > 正文

hdu4451

2013年06月16日 ⁄ 综合 ⁄ 共 2035字 ⁄ 字号 评论关闭

Dressing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1730    Accepted Submission(s): 734

Problem Description
Wangpeng has N clothes, M pants and K shoes so theoretically he can have N×M×K different combinations of dressing.
One day he wears his pants Nike, shoes Adiwang to go to school happily. When he opens the door, his mom asks him to come back and switch the dressing. Mom thinks that pants-shoes pair is disharmonious because Adiwang is much better than Nike. After being asked
to switch again and again Wangpeng figure out all the pairs mom thinks disharmonious. They can be only clothes-pants pairs or pants-shoes pairs.
Please calculate the number of different combinations of dressing under mom’s restriction.
 

Input
There are multiple test cases.
For each case, the first line contains 3 integers N,M,K(1≤N,M,K≤1000) indicating the number of clothes, pants and shoes.
Second line contains only one integer P(0≤P≤2000000) indicating the number of pairs which mom thinks disharmonious.
Next P lines each line will be one of the two forms“clothes x pants y” or “pants y shoes z”.
The first form indicates pair of x-th clothes and y-th pants is disharmonious(1≤x≤N,1 ≤y≤M), and second form indicates pair of y-th pants and z-th shoes is disharmonious(1≤y≤M,1≤z≤K).
Input ends with “0 0 0”.
It is guaranteed that all the pairs are different.
 

Output
For each case, output the answer in one line.
 

Sample Input
2 2 2 0 2 2 2 1 clothes 1 pants 1 2 2 2 2 clothes 1 pants 1 pants 1 shoes 1 0 0 0
 

Sample Output
8 6 5
 

Source
 

Recommend
zhuyuanchen520
本题比较简单,所有组合数-重复的。
#include<iostream>
#include<cstdio>
#include<string>
using namespace std;

int tmp1,tmp2;
int Map1[1000+10];
int Map2[1000+10];
string str1,str2;

int main()
{
	int n,m,k,q;
	int x,y,i;
	__int64 sum;
	while(~scanf("%d%d%d",&n,&m,&k))
	{
		if(0==n&&0==m&&0==k)break;
		sum=(__int64)n*m*k;tmp1=0;tmp2=0;
		memset(Map1,0,sizeof(Map1));
		memset(Map2,0,sizeof(Map2));
		scanf("%d",&q);
		while(q--)
		{
			//scanf("%s%d%s%d",str1,x,str2,y);
			cin>>str1>>x>>str2>>y;
			if(str1=="clothes")
			{
				tmp1++;
				Map1[y]++;
				//if(Map2[y])ans++;
			}
			else 
			{
				Map2[x]++;
				tmp2++;
				//if(Map1[x])ans++;
			}
		}
		sum-=(__int64)tmp1*k;
		sum-=(__int64)tmp2*n;
		for(i=1;i<=m;i++)
			sum+=(__int64)(Map1[i]*Map2[i]);
		printf("%I64d\n",sum);
	}
	system("pause");
	return 0;
}

抱歉!评论已关闭.