现在的位置: 首页 > 综合 > 正文

HDU1588

2013年08月23日 ⁄ 综合 ⁄ 共 2202字 ⁄ 字号 评论关闭

Gauss Fibonacci

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1654    Accepted Submission(s): 720

Problem Description
Without expecting, Angel replied quickly.She says: "I'v heard that you'r a very clever boy. So if you wanna me be your GF, you should solve the problem called GF~. "
How good an opportunity that Gardon can not give up! The "Problem GF" told by Angel is actually "Gauss Fibonacci".
As we know ,Gauss is the famous mathematician who worked out the sum from 1 to 100 very quickly, and Fibonacci is the crazy man who invented some numbers.

Arithmetic progression:
g(i)=k*i+b;
We assume k and b are both non-nagetive integers.

Fibonacci Numbers:
f(0)=0
f(1)=1
f(n)=f(n-1)+f(n-2) (n>=2)

The Gauss Fibonacci problem is described as follows:
Given k,b,n ,calculate the sum of every f(g(i)) for 0<=i<n
The answer may be very large, so you should divide this answer by M and just output the remainder instead.

 

Input
The input contains serveral lines. For each line there are four non-nagetive integers: k,b,n,M
Each of them will not exceed 1,000,000,000.
 

Output
For each line input, out the value described above.
 

Sample Input
2 1 4 100 2 0 4 100
 

Sample Output
21 12
 
//无法理解求和的Sum函数,哎~
#include<iostream>
#include<stdio.h>
#define ll long long
using namespace std;
struct Node
{
	ll mat[2][2];
};
const int n=2;
int k,b,nn,m;
Node unit,qiqi;
Node mul(const Node &a,const Node &b)
{
	Node c;
	int i,j,k;
	for(i=0;i<n;i++)
		for(j=0;j<n;j++)
		{
			c.mat[i][j]=0;
			for(k=0;k<n;k++)
				c.mat[i][j]+=(a.mat[i][k]*b.mat[k][j])%m;
			c.mat[i][j]%=m;
		}
	return c;
}
Node power(const Node &a,int x)
{
	int i,j;
	int t=x,d=0;
	while(t)
		d++,t>>=1;
	Node res=unit;
	for(i=d;i>0;i--)
	{
		res=mul(res,res);
		if(x&(1<<(i-1)))
			res=mul(res,a);
	}
	return res;
}
Node add(const Node &a,const Node &b)
{
	Node c;
	int i,j;
	for(i=0;i<n;i++)
		for(j=0;j<n;j++)
			c.mat[i][j]=(a.mat[i][j]+b.mat[i][j])%m;
	return c;
}

Node sum(const Node &a,int x)//A+A^2+……A^x
{
	if(x==1)
		return a;
	Node temp=sum(a,x>>1);
	if(x&1)
	{
		Node tmp=power(a,(x>>1)+1);
		return add(add(mul(temp,tmp),temp),tmp);
	}
	else
	{
		Node tmp=power(a,(x>>1));
		return add(mul(tmp,temp),temp);
	}
}
int main()
{
    for(int i=0;i<n;i++)
    for(int j=0;j<n;j++)
    unit.mat[i][j]=(i==j);
    qiqi.mat[0][0]=1;qiqi.mat[0][1]=1;qiqi.mat[1][0]=1;qiqi.mat[1][1]=0;
	while(scanf("%d%d%d%d",&k,&b,&nn,&m)!=EOF)
	{
	  Node res;
	  res=power(qiqi,k);//A^k
	  res=sum(res,nn-1);//A+A^2……+A^nn
	  res=add(res,unit);
	  Node ans=power(qiqi,b);
	  res=mul(ans,res);
	  printf("%I64d\n",res.mat[1][0]);
	}
	return 0;
}

抱歉!评论已关闭.