现在的位置: 首页 > 综合 > 正文

hdu1358

2013年11月29日 ⁄ 综合 ⁄ 共 1606字 ⁄ 字号 评论关闭

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2049    Accepted Submission(s): 1010

Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the
largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line,
having the number zero on it.
 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the
prefix sizes must be in increasing order. Print a blank line after each test case.
 

Sample Input
3 aaa 12 aabaabaabaab 0
 

Sample Output
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
 

Recommend
JGShining
 
本题要求所给字符串的长度大于等于2的可以由某一子串循环得到的前缀的长度和循环次数。
此题首先得求最小循环节,用KMP算法
 
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

const int MAXN=1000000+100;
char str[MAXN];//W为模式串,T为主串
int next[MAXN];

//KMP算法中计算next[]数组
void getNext(char *p)
{
    int j,k,len=strlen(p);
    j=0;
    k=-1;
    next[0]=-1;
    while(j<len)
    {
        if(k==-1||p[j]==p[k])
        {
            next[++j]=++k;
        }
        else k=next[k];
    }
}

int main()
{
	int n,i,tag=1;
	while(~scanf("%d",&n),n)
	{
		scanf("%s",str);
		getNext(str);
		printf("Test case #%d\n",tag++);
		for(i=2;i<=n;i++)
		{
			if(next[i]&&i%(i-next[i])==0)
				printf("%d %d\n",i,i/(i-next[i]));
		}
		printf("\n");
	}
	return 0;
}

抱歉!评论已关闭.