现在的位置: 首页 > 综合 > 正文

hdu 1219(1.2.8)

2013年01月06日 ⁄ 综合 ⁄ 共 1422字 ⁄ 字号 评论关闭

题目描述:AC Me

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3515 Accepted Submission(s): 1235
 
Problem Description
Ignatius is doing his homework now. The teacher gives him some articles and asks him to tell how many times each letter appears.

It's really easy, isn't it? So come on and AC ME.

 
Input
Each article consists of just one line, and all the letters are in lowercase. You just have to count the number of each letter, so do not pay attention to other characters. The length of article is at most 100000. Process to the end
of file.

Note: the problem has multi-cases, and you may use "while(gets(buf)){...}" to process to the end of file.

 
Output
For each article, you have to tell how many times each letter appears. The output format is like "X:N".

Output a blank line after each test case. More details in sample output.

 
Sample Input
hello, this is my first acm contest!
work hard for hdu acm.
 
Sample Output
a:1
b:0
c:2
d:0
e:2
f:1
g:0
h:2
i:3
j:0
k:0
l:2
m:2
n:1
o:2
p:0
q:0
r:1
s:4
t:4
u:0
v:0
w:0
x:0
y:1
z:0

a:2
b:0
c:1
d:2
e:0
f:1
g:0
h:2
i:0
j:0
k:1
l:0
m:1
n:0
o:2
p:0
q:0
r:3
s:0
t:0
u:1
v:0
w:1
x:0
y:0
z:0
 
Author
Ignatius.L
 
#include<stdio.h>

#include<stdlib.h>

#include<string.h>

int findout(char a)

{

   if(a>='a'&&a<='z')

      return a-'a'+1;

    else

       return 0;

}


int main()

{

   int len,i,c[27];

   char s[100005];

   while(gets(s))

   {

      memset(c,0,sizeof(c));

     

      len=strlen(s);

       for(i=0;i<len;i++)

         if(findout(s[i]))

            c[findout(s[i])]++;


      for(i=1;i<=26;i++)

      printf("%c:%d\n",'a'+i-1,c[i]); 

      printf("\n");

      memset(s,0,sizeof(s));

   }
   return 0;

}

总结:1.gest()读取一行的字符串,接受空格
            2.返回s的长度,不包括结束符NULL。
            3.不要轻易用while(len--)

抱歉!评论已关闭.