现在的位置: 首页 > 综合 > 正文

UVA490—— Rotating Sentences

2013年03月09日 ⁄ 综合 ⁄ 共 1078字 ⁄ 字号 评论关闭

In ``Rotating Sentences,'' you are asked to rotate a series of input sentences 90 degrees clockwise. So instead of displaying the input sentences from left to right and top to bottom, your program will display them from top to bottom and right to left.

Input and Output

As input to your program, you will be given a maximum of 100 sentences, each not exceeding 100 characters long. Legal characters include: newline, space, any punctuation characters, digits, and lower case or upper case English letters. (NOTE: Tabs are not
legal characters.)

The output of the program should have the last sentence printed out vertically in the leftmost column; the first sentence of the input would subsequently end up at the rightmost column.

Sample Input

Rene Decartes once said,
"I think, therefore I am."

Sample Output

"R
Ie
 n
te
h 
iD
ne
kc
,a
 r
tt
he
es
r
eo
fn
oc
re
e
 s
Ia
 i
ad
m,
.
"

分析:

90度大旋转!!!(本样例输出用大写B代替空格,但交题时小心,用空格);

#include<stdio.h>
#include<string.h>
char a[110][110];
int r,c;
int main()
{
    int i,j,len,k;
    memset(a,0,sizeof(a));
    r=0;   //记录列数
    c=0;    //记录行数
    while(gets(a[r]))
    {

        len=strlen(a[r]);
        if(len>c)
        {
            c=len;
        }
        r++;
    }
    for(i=0; i<r; i++)
        for(j=0; j<c; j++)
        {
            if(!a[i][j])
            {
                a[i][j]=' ';
            }
        }
    for(j=0; j<c; j++)
    {
        for(k=i-1; k>=0; k--)
            printf("%c",a[k][j]);
        printf("\n");
    }
    return 0;
}

 

抱歉!评论已关闭.