现在的位置: 首页 > 综合 > 正文

USACO1.3.2 Barn Repair(修理牛棚)

2013年11月24日 ⁄ 综合 ⁄ 共 1794字 ⁄ 字号 评论关闭

It was a dark and stormy night that ripped the roof and gates off the stalls that hold Farmer John's cows. Happily, many of the cows were on vacation, so the barn was not completely full.

The cows spend the night in stalls that are arranged adjacent to each other in a long line. Some stalls have cows in them; some do not. All stalls are the same width.

Farmer John must quickly erect new boards in front of the stalls, since the doors were lost. His new lumber supplier will supply him boards of any length he wishes, but the supplier can only deliver
a small number of total boards. Farmer John wishes to minimize the total length of the boards he must purchase.

Given M (1 <= M <= 50), the maximum number of boards that can be purchased; S (1 <= S <= 200), the total number of stalls; C (1 <= C <= S) the number of cows in the stalls, and the C occupied stall
numbers (1 <= stall_number <= S), calculate the minimum number of stalls that must be blocked in order to block all the stalls that have cows in them.

Print your answer as the total number of stalls blocked.

PROGRAM NAME: barn1

INPUT FORMAT

Line 1: M, S, and C (space separated)
Lines 2-C+1: Each line contains one integer, the number of an occupied stall.

SAMPLE INPUT (file barn1.in)

4 50 18
3
4
6
8
14
15
16
17
21
25
26
27
30
31
40
41
42
43

OUTPUT FORMAT

A single line with one integer that represents the total number of stalls blocked.

SAMPLE OUTPUT (file barn1.out)

25

[One minimum arrangement is one board covering stalls 3-8, one covering 14-21, one covering 25-31, and one covering 40-43.]

题目大意:简化为数轴上有C个被标记点,求用M个区间覆盖住所有被标记点所需的最小区间长度。

解题思路:这道题目是一个典型的贪心算法,最小覆盖长度等同于最大未覆盖长度,初始时可令一大区间覆盖数轴上全部点集,按次截去现有区间中最长未标记子区间,将木板截为M段即可。

贴上我的AC代码吧:

/*
USER:xingwen wang
TASK:barn1
LANG:C++
*/
#include<cstdio>
#include<algorithm>
int main()
{
    int i,n,m,T,s,t=0,a[201],b[201];
    freopen("barn1.in","r",stdin);
    freopen("barn1.out","w",stdout);
    scanf("%d%d%d",&m,&s,&n);
    for(i=1;i<=n;i++)
    scanf("%d",&a[i]);
    std::sort(a+1,a+n+1);
    for(i=1;i<n;i++)
    b[i]=a[i+1]-a[i]-1;
    std::sort(b+1,b+n);
    T=n-m>0?n-m+1:1;
    for(i=n-1;i>=T;i--)
    t+=b[i];
    printf("%d\n",a[n]-a[1]-t+1);
    return 0;
}

抱歉!评论已关闭.