现在的位置: 首页 > 综合 > 正文

2005. Lovely Number

2013年09月30日 ⁄ 综合 ⁄ 共 873字 ⁄ 字号 评论关闭

2005. Lovely Number

Description

Every time after got a solution from kevin, ivan repeats again and again,"Are there any better ones?". It seems more worse this time. Given a sequence of numbers, which ivan is sure that all of them appear even times except only one "lovely number" appears
odd times, kevin must find out the lovely number as soon as possible. So, let's rock!

 

Input

There are multiple test cases.

Each test case contains two lines. The first line is an integer N, 1 <= N <= 10001, and N % 2 = 1. The second line contains N integers, separated by spaces.

Input is terminated by EOF.

 

Output

For each test case, output a line of an integer, which should be the lovely number.

Sample Input

31 2 157 7 7 7 372 2 4 4 4 2 2

Sample Output

234

Problem Source

2010中山大学新手赛-网络预选赛 ivankevin@argo

#include <iostream>
#include <set>
using namespace std;

int main()
{
	int t;
	while(cin>>t)
	{
		int temp;
		set<int>myset;
		while(t--)
		{
			cin>>temp;
			if(myset.count(temp))
				myset.erase(temp);
			else
			    myset.insert(temp);
		}
		cout<<*myset.begin()<<endl;
	}
	return 0;
}

抱歉!评论已关闭.